summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-06-04 21:13:33 +0300
committerViktor Drobot2020-06-04 21:13:33 +0300
commitee8baeb0e658417a168380298848e2029d79ffd8 (patch)
treec2a7741280765bad4297ee3639f12eb7b6215c74
downloadaur-ee8baeb0e658417a168380298848e2029d79ffd8.tar.gz
First release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fad6b63beaf3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = r-corrplot
+ pkgdesc = Visualization of a Correlation Matrix
+ pkgver = 0.84
+ pkgrel = 1
+ url = https://cran.r-project.org/package=corrplot
+ arch = any
+ license = GPL2
+ license = GPL3
+ depends = r
+ optdepends = r-knitr
+ optdepends = r-rcolorbrewer
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/corrplot_0.84.tar.gz
+ md5sums = 9880c2dc88b7ec9a5c52d9dd064af21a
+
+pkgname = r-corrplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc30cc141b88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=corrplot
+_cranver=0.84
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Visualization of a Correlation Matrix"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL2 GPL3)
+depends=(r)
+optdepends=(r-knitr r-rcolorbrewer r-testthat)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('9880c2dc88b7ec9a5c52d9dd064af21a')
+
+build() {
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}