summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-10-17 07:47:31 +0300
committerPekka Ristola2023-10-17 07:47:31 +0300
commit24d96bbcc84e3f6a880994964d00dcca2d8a3ebf (patch)
tree55c4e4584498ab21d9f2dfb380dafc0a8f8ab76f
downloadaur-24d96bbcc84e3f6a880994964d00dcca2d8a3ebf.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD58
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fc118cf6793
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = r-cosia
+ pkgdesc = An Investigation Across Different Species and Tissues
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/CoSIA
+ arch = any
+ license = MIT
+ depends = r-annotationdbi
+ depends = r-annotationtools
+ depends = r-biomart
+ depends = r-dplyr
+ depends = r-experimenthub
+ depends = r-ggplot2
+ depends = r-homologene
+ depends = r-magrittr
+ depends = r-org.ce.eg.db
+ depends = r-org.dm.eg.db
+ depends = r-org.dr.eg.db
+ depends = r-org.hs.eg.db
+ depends = r-org.mm.eg.db
+ depends = r-org.rn.eg.db
+ depends = r-plotly
+ depends = r-rcolorbrewer
+ depends = r-readr
+ depends = r-stringr
+ depends = r-tibble
+ depends = r-tidyr
+ depends = r-tidyselect
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-qpdf
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ optdepends = r-tidyverse
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/CoSIA_1.0.0.tar.gz
+ md5sums = 3f8ef5bd89e113c1bf68ce002bd54140
+ sha256sums = 303452b7fa963d3a46e9344beb02dcf7ddb3650d3e45f547580e50496ac102c3
+
+pkgname = r-cosia
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f4b6d5731d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=CoSIA
+_pkgver=1.0.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="An Investigation Across Different Species and Tissues"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(MIT)
+depends=(
+ r-annotationdbi
+ r-annotationtools
+ r-biomart
+ r-dplyr
+ r-experimenthub
+ r-ggplot2
+ r-homologene
+ r-magrittr
+ r-org.ce.eg.db
+ r-org.dm.eg.db
+ r-org.dr.eg.db
+ r-org.hs.eg.db
+ r-org.mm.eg.db
+ r-org.rn.eg.db
+ r-plotly
+ r-rcolorbrewer
+ r-readr
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-tidyselect
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-qpdf
+ r-rmarkdown
+ r-testthat
+ r-tidyverse
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('3f8ef5bd89e113c1bf68ce002bd54140')
+sha256sums=('303452b7fa963d3a46e9344beb02dcf7ddb3650d3e45f547580e50496ac102c3')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}