summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-10-26 23:55:20 +0300
committerPekka Ristola2023-10-26 23:55:20 +0300
commita88a923ecdb688cf88af00c7ae7d38dd98633b78 (patch)
tree19a75cf27f43ce1dd5a20b8e76b9fec68682716f
parent585195e957af4e76fece355793618f9851aa6fec (diff)
downloadaur-a88a923ecdb688cf88af00c7ae7d38dd98633b78.tar.gz
Fix tests
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
-rw-r--r--fix-tests.patch28
3 files changed, 44 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f53d1d65f06a..8ad0f65a3b5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-cpp11
pkgdesc = A C++11 Interface for R's C Interface
pkgver = 0.4.6
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=cpp11
arch = any
license = MIT
@@ -32,7 +32,10 @@ pkgbase = r-cpp11
optdepends = r-vctrs
optdepends = r-withr
source = https://cran.r-project.org/src/contrib/cpp11_0.4.6.tar.gz
+ source = fix-tests.patch
md5sums = 786e1fdd894c982290d4ae401123fe59
+ md5sums = 7b7abe5ee87b665f50a36776475111ce
sha256sums = d1c56954671d3398078ad52aaa4efce0864e8166465c8c5e5e9a1e40599055b3
+ sha256sums = 88d4f13e8b518250c520c906784f68971782a470f5451e510c3b25b47f3b11b9
pkgname = r-cpp11
diff --git a/PKGBUILD b/PKGBUILD
index cc0e570f6f94..6193f49501bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=cpp11
_pkgver=0.4.6
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=1
+pkgrel=2
pkgdesc="A C++11 Interface for R's C Interface"
arch=(any)
url="https://cran.r-project.org/package=${_pkgname}"
@@ -43,9 +43,17 @@ optdepends=(
r-vctrs
r-withr
)
-source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('786e1fdd894c982290d4ae401123fe59')
-sha256sums=('d1c56954671d3398078ad52aaa4efce0864e8166465c8c5e5e9a1e40599055b3')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-tests.patch")
+md5sums=('786e1fdd894c982290d4ae401123fe59'
+ '7b7abe5ee87b665f50a36776475111ce')
+sha256sums=('d1c56954671d3398078ad52aaa4efce0864e8166465c8c5e5e9a1e40599055b3'
+ '88d4f13e8b518250c520c906784f68971782a470f5451e510c3b25b47f3b11b9')
+
+prepare() {
+ # fix test snapshots
+ patch -Np1 -i fix-tests.patch
+}
build() {
mkdir -p build
diff --git a/fix-tests.patch b/fix-tests.patch
new file mode 100644
index 000000000000..68e10224632f
--- /dev/null
+++ b/fix-tests.patch
@@ -0,0 +1,28 @@
+diff --git a/cpp11/tests/testthat/_snaps/register.md b/cpp11/tests/testthat/_snaps/register.md
+index 0e4b143..75125c4 100644
+--- a/cpp11/tests/testthat/_snaps/register.md
++++ b/cpp11/tests/testthat/_snaps/register.md
+@@ -2,7 +2,7 @@
+
+ Code
+ cpp_register(p, quiet = FALSE)
+- Message <cliMessage>
++ Message
+ i 1 functions decorated with [[cpp11::register]]
+ v generated file 'cpp11.R'
+ v generated file 'cpp11.cpp'
+diff --git a/cpp11/tests/testthat/_snaps/source.md b/cpp11/tests/testthat/_snaps/source.md
+index 1593503..ad9152a 100644
+--- a/cpp11/tests/testthat/_snaps/source.md
++++ b/cpp11/tests/testthat/_snaps/source.md
+@@ -2,7 +2,8 @@
+
+ Code
+ cpp_source(i_do_not_exist)
+- Error <simpleError>
+- Can't find `file` at this path:
++ Condition
++ Error:
++ ! Can't find `file` at this path:
+ {NON_EXISTENT_FILEPATH}
+