summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2017-09-28 11:07:09 -0500
committerStephen Martin2017-09-28 11:07:09 -0500
commitf17e5f65cf319ce8862dbb4a624e5fc3c5bb1493 (patch)
tree3732852ba77b4a4961a119fdeb8f98e64ee165fc
downloadaur-f17e5f65cf319ce8862dbb4a624e5fc3c5bb1493.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a81ab021e760
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Sep 28 16:06:55 UTC 2017
+pkgbase = r-cran-rcpp
+ pkgdesc = Seamless R and C++ Integration
+ pkgver = 0.2.14
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/RInside/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ depends = r
+ depends = r-cran-rcpp
+ source = http://cran.r-project.org/src/contrib/RInside_0.2.14.tar.gz
+ md5sums = fc72761e22b1f597433eb53d6eb122ff
+
+pkgname = r-cran-rcpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3892c9e38454
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Stephen R. Martin <stephensrmmartin at gmail dot com>
+_cranname=RInside
+_cranver=0.2.14
+pkgname=r-cran-rcpp
+pkgver=${_cranver}
+pkgrel=1
+pkgdesc="Seamless R and C++ Integration"
+url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('i686' 'x86_64')
+license=('GPL2' 'GPL3')
+depends=('r' 'r-cran-rcpp')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('fc72761e22b1f597433eb53d6eb122ff')
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd ${srcdir}
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}