summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-09-18 17:36:34 +0300
committerPekka Ristola2023-09-18 17:36:34 +0300
commitcd64be4a8b8bf9382698b2c43671f8dcd826f13f (patch)
tree70155a43368143f1764f48ad1b5bf086815da413
downloadaur-cd64be4a8b8bf9382698b2c43671f8dcd826f13f.tar.gz
Version 1.1.2
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ab8c1dc79cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-crch
+ pkgdesc = Censored Regression with Conditional Heteroscedasticity
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://cran.r-project.org/package=crch
+ arch = x86_64
+ license = GPL
+ depends = r-formula
+ depends = r-ordinal
+ depends = r-sandwich
+ depends = r-scoringrules
+ optdepends = r-distributions3
+ optdepends = r-glmx
+ optdepends = r-lmtest
+ optdepends = r-memisc
+ source = https://cran.r-project.org/src/contrib/crch_1.1-2.tar.gz
+ md5sums = a34563d6831ca92c894669ba9020dc19
+ sha256sums = 38a7a72fcbdcdc7a7a256e80b08f2213a8e3073acc091d175f3a141c11ae8ac7
+
+pkgname = r-crch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78309c2742a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=crch
+_pkgver=1.1-2
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Censored Regression with Conditional Heteroscedasticity"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(GPL)
+depends=(
+ r-formula
+ r-ordinal
+ r-sandwich
+ r-scoringrules
+)
+optdepends=(
+ r-distributions3
+ r-glmx
+ r-lmtest
+ r-memisc
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('a34563d6831ca92c894669ba9020dc19')
+sha256sums=('38a7a72fcbdcdc7a7a256e80b08f2213a8e3073acc091d175f3a141c11ae8ac7')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}