summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-12-13 14:47:34 +0300
committerViktor Drobot2020-12-13 14:47:34 +0300
commit407e2bd4665a82d21f308e306bc4ed1901dec773 (patch)
tree6ebeb453546979909a3aa38ca35edddb4909a633
downloadaur-407e2bd4665a82d21f308e306bc4ed1901dec773.tar.gz
Initial release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50ca3c3b6646
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = r-credentials
+ pkgdesc = Tools for Managing SSH and Git Credentials
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://cran.r-project.org/package=credentials
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-openssl>=1.3
+ depends = r-sys>=2.1
+ depends = r-curl
+ depends = r-jsonlitr
+ depends = r-askpass
+ optdepends = r-testthat
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = git
+ source = https://cran.r-project.org/src/contrib/credentials_1.3.0.tar.gz
+ sha256sums = c119ec26fd97b977c3b0cd1eb8fad3c59b84df6262c3adbf5ee9f3d6c9903ff1
+
+pkgname = r-credentials
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b355c062d868
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=credentials
+_cranver=1.3.0
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Tools for Managing SSH and Git Credentials"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(MIT)
+depends=(r 'r-openssl>=1.3' 'r-sys>=2.1' r-curl r-jsonlitr r-askpass)
+optdepends=(r-testthat r-knitr r-rmarkdown git)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=('c119ec26fd97b977c3b0cd1eb8fad3c59b84df6262c3adbf5ee9f3d6c9903ff1')
+
+build() {
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}