summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-10-17 15:38:33 +0300
committerPekka Ristola2023-10-17 15:38:33 +0300
commit6998030de1dc824215110d5af750cd11ba3914b3 (patch)
tree571cdc0585f571e74703597e5706039476d60572
downloadaur-6998030de1dc824215110d5af750cd11ba3914b3.tar.gz
Version 1.0.2
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f3854f58ad1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-ctdata
+ pkgdesc = Data companion to CTexploreR
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://bioconductor.org/packages/CTdata
+ arch = any
+ license = Artistic2.0
+ checkdepends = r-testthat
+ depends = r-experimenthub
+ optdepends = r-biocstyle
+ optdepends = r-dt
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-summarizedexperiment
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/CTdata_1.0.2.tar.gz
+ md5sums = e5666dc0fc962f452b36e1469947dd28
+ sha256sums = 26f52c57b4b6d476d5d3f2d78888688522030d48637132f2f7cb251804142ab8
+
+pkgname = r-ctdata
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5afebbf7c4ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=CTdata
+_pkgver=1.0.2
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Data companion to CTexploreR"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(Artistic2.0)
+depends=(
+ r-experimenthub
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-dt
+ r-knitr
+ r-rmarkdown
+ r-summarizedexperiment
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('e5666dc0fc962f452b36e1469947dd28')
+sha256sums=('26f52c57b4b6d476d5d3f2d78888688522030d48637132f2f7cb251804142ab8')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}