summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-30 15:26:01 +0200
committerPekka Ristola2023-11-30 15:26:01 +0200
commitfc080b0f34b128e0aa383a9d46706eebac692232 (patch)
tree53cab0a62663d7ba1cc76122a5bae88da62699bd
downloadaur-fc080b0f34b128e0aa383a9d46706eebac692232.tar.gz
Version 1.4.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8de827b07308
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-ctsv
+ pkgdesc = Identification of cell-type-specific spatially variable genes accounting for excess zeros
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/CTSV
+ arch = any
+ license = GPL3
+ checkdepends = r-testthat
+ depends = r-biocparallel
+ depends = r-knitr
+ depends = r-pscl
+ depends = r-qvalue
+ depends = r-spatialexperiment
+ depends = r-summarizedexperiment
+ optdepends = r-biocstyle
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/CTSV_1.4.0.tar.gz
+ md5sums = 4a3f8c7b5398449ea01b312ed7da1f43
+ sha256sums = c9ab303473fa093de52c3a25dc2e46413399cef5284aa2c177299c03e61fcc02
+
+pkgname = r-ctsv
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..233b10c9a976
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=CTSV
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Identification of cell-type-specific spatially variable genes accounting for excess zeros"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-biocparallel
+ r-knitr
+ r-pscl
+ r-qvalue
+ r-spatialexperiment
+ r-summarizedexperiment
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('4a3f8c7b5398449ea01b312ed7da1f43')
+sha256sums=('c9ab303473fa093de52c3a25dc2e46413399cef5284aa2c177299c03e61fcc02')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}