summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:34:11 +0800
committerSukanka2022-06-06 07:34:11 +0800
commitb71f0eb974c7b3c4b8ea826cd26f6e2deed50092 (patch)
treeba0b3596ccf6c855c755ff218f10246aabfff744
downloadaur-b71f0eb974c7b3c4b8ea826cd26f6e2deed50092.tar.gz
add r-cytoml
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD64
2 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..077e6dc0cdd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = r-cytoml
+ pkgdesc = A GatingML Interface for Cross Platform Cytometry Data Sharing
+ pkgver = 2.8.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/CytoML
+ arch = x86_64
+ license = custom
+ depends = r
+ depends = r-base64enc
+ depends = r-bh
+ depends = r-biobase
+ depends = r-corpcor
+ depends = r-cytolib
+ depends = r-data.table
+ depends = r-dplyr
+ depends = r-flowcore
+ depends = r-flowworkspace
+ depends = r-ggcyto
+ depends = r-graph
+ depends = r-jsonlite
+ depends = r-opencyto
+ depends = r-plyr
+ depends = r-rbgl
+ depends = r-rcpp
+ depends = r-rcpparmadillo
+ depends = r-rcppparallel
+ depends = r-rgraphviz
+ depends = r-rhdf5lib
+ depends = r-rprotobuflib
+ depends = r-runit
+ depends = r-tibble
+ depends = r-xml
+ depends = r-xml2
+ depends = r-yaml
+ depends = gcc
+ depends = make
+ depends = libxml2
+ optdepends = r-flowworkspacedata
+ optdepends = r-knitr
+ optdepends = r-parallel
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/CytoML_2.8.0.tar.gz
+ sha256sums = 399f4daacc8b69adc47f9a804041af443d28b5f2ea5f094d2aa805e87653e76e
+
+pkgname = r-cytoml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5555fff9937b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# system requirements: xml2, GNU make, C++11
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=CytoML
+_pkgver=2.8.0
+pkgname=r-${_pkgname,,}
+pkgver=2.8.0
+pkgrel=1
+pkgdesc='A GatingML Interface for Cross Platform Cytometry Data Sharing'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('custom')
+depends=(
+ r
+ r-base64enc
+ r-bh
+ r-biobase
+ r-corpcor
+ r-cytolib
+ r-data.table
+ r-dplyr
+ r-flowcore
+ r-flowworkspace
+ r-ggcyto
+ r-graph
+ r-jsonlite
+ r-opencyto
+ r-plyr
+ r-rbgl
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppparallel
+ r-rgraphviz
+ r-rhdf5lib
+ r-rprotobuflib
+ r-runit
+ r-tibble
+ r-xml
+ r-xml2
+ r-yaml
+ gcc
+ make
+ libxml2
+)
+optdepends=(
+ r-flowworkspacedata
+ r-knitr
+ r-parallel
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('399f4daacc8b69adc47f9a804041af443d28b5f2ea5f094d2aa805e87653e76e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: