summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:43:10 +0800
committerSukanka2022-06-06 07:43:10 +0800
commitd423040f5442a2a351893c3bad23967621e0f7c1 (patch)
treea6a57a7fe9039fe52dec094e0aae0282cab1964b
downloadaur-d423040f5442a2a351893c3bad23967621e0f7c1.tar.gz
add r-dearseq
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD54
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e39921b3a4f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = r-dearseq
+ pkgdesc = Differential Expression Analysis for RNA-seq data through a robust variance component test
+ pkgver = 1.8.1
+ pkgrel = 1
+ url = https://bioconductor.org/packages/dearseq
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-ggplot2
+ depends = r-matrixstats
+ depends = r-patchwork
+ depends = r-pbapply
+ depends = r-statmod
+ depends = r-survey
+ depends = r-viridislite
+ depends = r-compquadform
+ depends = r-reshape2
+ depends = r-plyr
+ depends = r-dplyr
+ optdepends = r-biobase
+ optdepends = r-biocmanager
+ optdepends = r-biocset
+ optdepends = r-covr
+ optdepends = r-deseq2
+ optdepends = r-edger
+ optdepends = r-geoquery
+ optdepends = r-gsa
+ optdepends = r-knitr
+ optdepends = r-limma
+ optdepends = r-readxl
+ optdepends = r-rmarkdown
+ optdepends = r-s4vectors
+ optdepends = r-summarizedexperiment
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/dearseq_1.8.1.tar.gz
+ sha256sums = 415e466e09d170fb67e87ca0c8e66a21cd1dabc83a2e4dadae8c32fdca2424b8
+
+pkgname = r-dearseq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3957eb5a466a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=dearseq
+_pkgver=1.8.1
+pkgname=r-${_pkgname,,}
+pkgver=1.8.1
+pkgrel=1
+pkgdesc='Differential Expression Analysis for RNA-seq data through a robust variance component test'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ggplot2
+ r-matrixstats
+ r-patchwork
+ r-pbapply
+ r-statmod
+ r-survey
+ r-viridislite
+ r-compquadform
+ r-reshape2
+ r-plyr
+ r-dplyr
+)
+optdepends=(
+ r-biobase
+ r-biocmanager
+ r-biocset
+ r-covr
+ r-deseq2
+ r-edger
+ r-geoquery
+ r-gsa
+ r-knitr
+ r-limma
+ r-readxl
+ r-rmarkdown
+ r-s4vectors
+ r-summarizedexperiment
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('415e466e09d170fb67e87ca0c8e66a21cd1dabc83a2e4dadae8c32fdca2424b8')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: