summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:43:56 +0800
committerSukanka2022-06-06 07:43:56 +0800
commit2d6cfec38d07ada808d395ce9d6f04d5a49d954d (patch)
tree425f2c60dd344d33d7c7e2d54f3b0684aaa2be8d
downloadaur-2d6cfec38d07ada808d395ce9d6f04d5a49d954d.tar.gz
add r-debrowser
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD66
2 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36059443958e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = r-debrowser
+ pkgdesc = Interactive Differential Expresion Analysis Browser
+ pkgver = 1.24.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/debrowser
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-annotate
+ depends = r-annotationdbi
+ depends = r-apeglm
+ depends = r-ashr
+ depends = r-clusterprofiler
+ depends = r-colourpicker
+ depends = r-deseq2
+ depends = r-dose
+ depends = r-dt
+ depends = r-edger
+ depends = r-enrichplot
+ depends = r-genomicranges
+ depends = r-ggplot2
+ depends = r-gplots
+ depends = r-harman
+ depends = r-heatmaply
+ depends = r-igraph
+ depends = r-iranges
+ depends = r-jsonlite
+ depends = r-limma
+ depends = r-org.hs.eg.db
+ depends = r-org.mm.eg.db
+ depends = r-pathview
+ depends = r-plotly
+ depends = r-rcolorbrewer
+ depends = r-rcurl
+ depends = r-reshape2
+ depends = r-s4vectors
+ depends = r-shiny
+ depends = r-shinybs
+ depends = r-shinydashboard
+ depends = r-shinyjs
+ depends = r-stringi
+ depends = r-summarizedexperiment
+ depends = r-sva
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/debrowser_1.24.0.tar.gz
+ sha256sums = 0e2111e2a726b5d93fb4d0f624e83b6aca39be0a083f2eb6268f603c312a6b0c
+
+pkgname = r-debrowser
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..461996179d32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=debrowser
+_pkgver=1.24.0
+pkgname=r-${_pkgname,,}
+pkgver=1.24.0
+pkgrel=1
+pkgdesc='Interactive Differential Expresion Analysis Browser'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-annotate
+ r-annotationdbi
+ r-apeglm
+ r-ashr
+ r-clusterprofiler
+ r-colourpicker
+ r-deseq2
+ r-dose
+ r-dt
+ r-edger
+ r-enrichplot
+ r-genomicranges
+ r-ggplot2
+ r-gplots
+ r-harman
+ r-heatmaply
+ r-igraph
+ r-iranges
+ r-jsonlite
+ r-limma
+ r-org.hs.eg.db
+ r-org.mm.eg.db
+ r-pathview
+ r-plotly
+ r-rcolorbrewer
+ r-rcurl
+ r-reshape2
+ r-s4vectors
+ r-shiny
+ r-shinybs
+ r-shinydashboard
+ r-shinyjs
+ r-stringi
+ r-summarizedexperiment
+ r-sva
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('0e2111e2a726b5d93fb4d0f624e83b6aca39be0a083f2eb6268f603c312a6b0c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: