summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxgdgsc2015-06-12 20:19:50 +0800
committerxgdgsc2015-06-12 20:19:50 +0800
commit523367907473c347ca06badd68f451ec13e0e957 (patch)
treeda0e2bb4cdb7f9105be9a0111bf045f8ac0f1e44
downloadaur-523367907473c347ca06badd68f451ec13e0e957.tar.gz
Initial import
-rw-r--r--.AURINFO46
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD94
-rw-r--r--R.conf2
-rw-r--r--r.desktop11
-rw-r--r--r.install16
-rw-r--r--r.pngbin0 -> 4771 bytes
7 files changed, 219 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..4ef3bf2333e4
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,46 @@
+pkgbase = r-devel
+ pkgdesc = Language and environment for statistical computing and graphics
+ pkgver = latest
+ pkgrel = 1
+ url = http://www.r-project.org/
+ install = r.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ makedepends = tk
+ depends = blas
+ depends = lapack
+ depends = bzip2
+ depends = libpng
+ depends = libjpeg
+ depends = libtiff
+ depends = ncurses
+ depends = pcre
+ depends = readline
+ depends = zlib
+ depends = perl
+ depends = gcc-libs
+ depends = libxt
+ depends = libxmu
+ depends = pango
+ depends = xz
+ depends = desktop-file-utils
+ depends = zip
+ depends = unzip
+ optdepends = tk: tcl/tk interface
+ optdepends = texlive-bin: latex sty files
+ source = ftp://ftp.stat.math.ethz.ch/Software/R/R-devel.tar.gz
+ source = r.desktop
+ source = r.png
+ source = R.conf
+ options = !makeflags
+ options = !emptydirs
+ backup = etc/R-devel/Makeconf
+ backup = etc/R-devel/Renviron
+ backup = etc/R-devel/ldpaths
+ backup = etc/R-devel/repositories
+ backup = etc/R-devel/javaconf
+
+pkgname = r-devel
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c30d69d70b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = r-devel
+ pkgdesc = Language and environment for statistical computing and graphics
+ pkgver = latest
+ pkgrel = 1
+ url = http://www.r-project.org/
+ install = r.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ makedepends = tk
+ depends = blas
+ depends = lapack
+ depends = bzip2
+ depends = libpng
+ depends = libjpeg
+ depends = libtiff
+ depends = ncurses
+ depends = pcre
+ depends = readline
+ depends = zlib
+ depends = perl
+ depends = gcc-libs
+ depends = libxt
+ depends = libxmu
+ depends = pango
+ depends = xz
+ depends = desktop-file-utils
+ depends = zip
+ depends = unzip
+ optdepends = tk: tcl/tk interface
+ optdepends = texlive-bin: latex sty files
+ options = !makeflags
+ options = !emptydirs
+ backup = etc/R-devel/Makeconf
+ backup = etc/R-devel/Renviron
+ backup = etc/R-devel/ldpaths
+ backup = etc/R-devel/repositories
+ backup = etc/R-devel/javaconf
+ source = ftp://ftp.stat.math.ethz.ch/Software/R/R-devel.tar.gz
+ source = r.desktop
+ source = r.png
+ source = R.conf
+ sha1sums = SKIP
+ sha1sums = d7fa521345b230a4187d60d07d06ce4b6d573e3f
+ sha1sums = a69a07ec363440efc18ce0a7f2af103375dea978
+ sha1sums = a2a2d672b4b123d8305666444680cb4f6909261b
+
+pkgname = r-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a032817b6a38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,94 @@
+# $Id: PKGBUILD 218371 2014-07-30 10:32:55Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+# Contributor: K. Piche <kpiche@rogers.com>
+
+pkgname=r-devel
+pkgver=latest
+pkgrel=1
+pkgdesc="Language and environment for statistical computing and graphics"
+arch=('i686' 'x86_64')
+license=('GPL')
+url=('http://www.r-project.org/')
+depends=('blas' 'lapack' 'bzip2' 'libpng' 'libjpeg' 'libtiff'
+ 'ncurses' 'pcre' 'readline' 'zlib' 'perl' 'gcc-libs'
+ 'libxt' 'libxmu' 'pango' 'xz' 'desktop-file-utils' 'zip' 'unzip')
+makedepends=('gcc-fortran' 'tk')
+optdepends=('tk: tcl/tk interface' 'texlive-bin: latex sty files')
+backup=('etc/R-devel/Makeconf' 'etc/R-devel/Renviron' 'etc/R-devel/ldpaths' 'etc/R-devel/repositories' 'etc/R-devel/javaconf')
+options=('!makeflags' '!emptydirs')
+install=r.install
+source=("ftp://ftp.stat.math.ethz.ch/Software/R/R-devel.tar.gz"
+ 'r.desktop'
+ 'r.png'
+ 'R.conf')
+sha1sums=('SKIP'
+ 'd7fa521345b230a4187d60d07d06ce4b6d573e3f'
+ 'a69a07ec363440efc18ce0a7f2af103375dea978'
+ 'a2a2d672b4b123d8305666444680cb4f6909261b')
+
+prepare() {
+ cd R-devel
+ # set texmf dir correctly in makefile
+ sed -i 's|$(rsharedir)/texmf|${datarootdir}/texmf|' share/Makefile.in
+ # fix for texinfo 5.X
+ sed -i 's|test ${makeinfo_version_min} -lt 7|test ${makeinfo_version_min} -lt 0|' configure
+}
+
+build() {
+ cd R-devel
+ ./configure --prefix=/usr/local \
+ --libdir=/usr/local/lib \
+ --sysconfdir=/etc/R-devel \
+ --datarootdir=/usr/local/share \
+ rsharedir=/usr/local/share/R/ \
+ rincludedir=/usr/local/include/R/ \
+ rdocdir=/usr/local/share/doc/R/ \
+ --with-x \
+ --enable-R-shlib \
+ --with-lapack \
+ --with-blas \
+ F77=gfortran \
+ LIBnn=lib
+ make
+
+# make libRmath.so
+ cd src/nmath/standalone
+ make shared
+}
+
+package() {
+ cd R-devel
+ make DESTDIR="${pkgdir}" install
+
+# install libRmath.so
+ cd src/nmath/standalone
+ make DESTDIR="${pkgdir}" install
+
+ # Fixup R wrapper scripts.
+ sed -i "s|${pkgdir} ||" "${pkgdir}/usr/local/bin/R"
+ # rm "${pkgdir}/usr/local/lib/R/bin/R"
+ cd "${pkgdir}/usr/local/lib/R/bin"
+
+ #ln -s ../../../local/bin/R-devel
+ #rename bin
+ mv "${pkgdir}/usr/local/bin/R" "${pkgdir}/usr/local/bin/R-devel"
+ mv "${pkgdir}/usr/local/bin/Rscript" "${pkgdir}/usr/local/bin/Rscript-devel"
+
+ # install some freedesktop.org compatibility
+ install -Dm644 "${srcdir}/r.desktop" \
+ "${pkgdir}/usr/local/share/applications/r.desktop"
+ install -Dm644 "${srcdir}/r.png" \
+ "${pkgdir}/usr/local/share/pixmaps/r.png"
+
+ # move the config directory to /etc and create symlinks
+ install -d "${pkgdir}/etc/R-devel"
+ cd "${pkgdir}/usr/local/lib/R/etc"
+ for i in *; do
+ mv -f ${i} "${pkgdir}/etc/R-devel"
+ ln -s /etc/R/${i} ${i}
+ done
+
+ # Install ld.so.conf.d file to ensure other applications access the shared lib
+ install -Dm644 "${srcdir}/R.conf" "${pkgdir}/etc/ld.so.conf.d/R-devel.conf"
+}
diff --git a/R.conf b/R.conf
new file mode 100644
index 000000000000..ef0c2a77a8f1
--- /dev/null
+++ b/R.conf
@@ -0,0 +1,2 @@
+/usr/local/lib/R/lib
+
diff --git a/r.desktop b/r.desktop
new file mode 100644
index 000000000000..7732c9bed1f8
--- /dev/null
+++ b/r.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=R
+GenericName=environment for statistical computing
+Comment=language and environment for statistical computing and graphics
+Exec=R
+Icon=/usr/share/pixmaps/r.png
+DocPath=/usr/lib/R/doc/html/index.html
+StartupNotify=true
+Terminal=true
+Type=Application
+Categories=Science;
diff --git a/r.install b/r.install
new file mode 100644
index 000000000000..522ce52e7b1f
--- /dev/null
+++ b/r.install
@@ -0,0 +1,16 @@
+post_install() {
+ update-desktop-database -q
+ if [[ -x /usr/bin/mktexlsr ]]; then
+ echo ">>> updating the filename database for texlive..."
+ mktexlsr --quiet usr/share/texmf
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
diff --git a/r.png b/r.png
new file mode 100644
index 000000000000..1303ccdb9641
--- /dev/null
+++ b/r.png
Binary files differ