summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-07-15 18:02:34 +0000
committerBioArchLinuxBot2023-07-15 18:02:34 +0000
commit156261f84bdc319b36a362cb1c7d459c686a66fb (patch)
tree3a5bd5a32b24f36c383b3d52277f67b6b2a40056
parent6d437cb86191e622f9ebb94a48de25164c1189a4 (diff)
downloadaur-156261f84bdc319b36a362cb1c7d459c686a66fb.tar.gz
[lilac] updated to 0.6.33-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD48
2 files changed, 45 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa142145dc2b..b1cf3d5357c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,20 @@
pkgbase = r-digest
pkgdesc = Create Compact Hash Digests of R Objects
pkgver = 0.6.33
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=digest
arch = x86_64
license = GPL
+ checkdepends = r-tinytest
+ depends = google-crc32c
+ depends = libblake3
depends = r
+ depends = xxhash
+ depends = zlib
optdepends = r-simplermarkdown
optdepends = r-tinytest
source = https://cran.r-project.org/src/contrib/digest_0.6.33.tar.gz
+ md5sums = f47359e9e90e279714c9fd50a47ad2ed
sha256sums = be702c886b1639be7eda4ea25a4261b30ce418c580f79bd78ec8d6cb4d327819
pkgname = r-digest
diff --git a/PKGBUILD b/PKGBUILD
index babc758d5a69..b2c3ad2fdc40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,61 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: frichtlm <frichtlm@gmail.com>
# Contributor: Grey Christoforo <first name at last name dot net>
+# Contributor: Alex Branham <alex.branham@gmail.com>
+# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
+# Contributor: Francois Garillot <francois[@]garillot.net>
_pkgname=digest
_pkgver=0.6.33
pkgname=r-${_pkgname,,}
-pkgver=0.6.33
-pkgrel=1
-pkgdesc='Create Compact Hash Digests of R Objects'
-arch=('x86_64')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Create Compact Hash Digests of R Objects"
+arch=(x86_64)
url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+license=(GPL)
depends=(
+ google-crc32c
+ libblake3
r
+ xxhash
+ zlib
+)
+checkdepends=(
+ r-tinytest
)
optdepends=(
r-simplermarkdown
r-tinytest
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('f47359e9e90e279714c9fd50a47ad2ed')
sha256sums=('be702c886b1639be7eda4ea25a4261b30ce418c580f79bd78ec8d6cb4d327819')
+prepare() {
+ cd "$_pkgname/src"
+ # use system blake3, crc32c, xxhash and zlib
+ rm -r crc32c
+ rm blake3* crc32.* crc32c* xxhash.* z*
+ sed -i 's/digest_crc32/crc32/' digest.c
+ sed -e 's|PKG_CPPFLAGS = -I.|PKG_CPPFLAGS = -I/usr/include/crc32c -I.|' \
+ -e '2 a PKG_LIBS = -lblake3 -lcrc32c -lxxhash -lz' \
+ -i Makevars
+}
+
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" Rscript --vanilla tinytest.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: