summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-29 10:07:38 -0500
committerAlex Branham2018-05-29 10:07:38 -0500
commit244f9564010ec9da97a31422360e8530d69d25ca (patch)
tree5e2d5b16dabd5b7fe04dc7f4d2d00c7b1d1ed7a6
parent9121bbc2e9787b2c83e067a014e88050548c54e0 (diff)
downloadaur-244f9564010ec9da97a31422360e8530d69d25ca.tar.gz
Improve PKGBUILD
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD21
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4d7a0ff868e..539faaa12023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = r-digest
-pkgdesc = Create compact hash digests of R objects
-pkgver = 0.6.15
-pkgrel = 1
-url = https://cran.r-project.org/web/packages/digest/index.html
-arch = x86_64
-license = GPL
-optdepends = r-knitr
-optdepends = r-rmarkdown
-source = https://cran.r-project.org/src/contrib/digest_0.6.15.tar.gz
-md5sums = 94fe9e133a7fb19a89e05daac7b5e9da
+ pkgdesc = Create compact hash digests of R objects
+ pkgver = 0.6.15
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/digest/index.html
+ arch = any
+ license = GPL
+ depends = r
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://cran.r-project.org/src/contrib/digest_0.6.15.tar.gz
+ md5sums = 94fe9e133a7fb19a89e05daac7b5e9da
pkgname = r-digest
diff --git a/PKGBUILD b/PKGBUILD
index cb5b752999f5..db872a7a36ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
# Maintainer: Alex Branham <branham@utexas.edu>
-# Contributor: generated by script at https://github.com/zasdfgbnm/aurcran
_cranname=digest
_cranver=0.6.15
+_pkgtar=${_cranname}_${_cranver}.tar.gz
pkgname=r-digest
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Create compact hash digests of R objects"
+arch=('any')
url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
-arch=('x86_64')
license=('GPL')
-optdepends=('r-knitr'
- 'r-rmarkdown')
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+depends=('r' )
+
+optdepends=('r-knitr' 'r-rmarkdown')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
md5sums=('94fe9e133a7fb19a89e05daac7b5e9da')
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
package() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd "${srcdir}"
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
}
+