summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 08:23:35 +0800
committerSukanka2022-06-06 08:23:35 +0800
commitcdb666a1aa3c1b523f56eb0db83f944d2e30316c (patch)
treefe6c6e0a15a054908b3ed2bfad1a15c7d88f6269
downloadaur-r-dmwr2.tar.gz
add r-dmwr2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8db4f5fbee1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = r-dmwr2
+ pkgdesc = Functions and Data for the Second Edition of "Data Mining with R"
+ pkgver = 0.0.2
+ pkgrel = 4
+ url = https://cran.r-project.org/package=DMwR2
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-dbi
+ depends = r-dplyr
+ depends = r-quantmod
+ depends = r-readr
+ depends = r-xts
+ depends = r-zoo
+ source = https://cran.r-project.org/src/contrib/DMwR2_0.0.2.tar.gz
+ sha256sums = 2902e83a8bd8b37c478c71eba005b436a7b4f2136dbc78a1c8481630c55feeef
+
+pkgname = r-dmwr2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e757e8ed56b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=DMwR2
+_pkgver=0.0.2
+pkgname=r-${_pkgname,,}
+pkgver=0.0.2
+pkgrel=4
+pkgdesc='Functions and Data for the Second Edition of "Data Mining with R"'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-dbi
+ r-dplyr
+ r-quantmod
+ r-readr
+ r-xts
+ r-zoo
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2902e83a8bd8b37c478c71eba005b436a7b4f2136dbc78a1c8481630c55feeef')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: