summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWard Segers2018-12-18 00:03:07 +0100
committerWard Segers2018-12-18 00:03:07 +0100
commitb604a907f607ec6969965a45c2c72f328620d0e6 (patch)
treefae9121932f5954bcdb8f2ad8a05867599ec62f3
downloadaur-b604a907f607ec6969965a45c2c72f328620d0e6.tar.gz
r-e1071
-rw-r--r--.SRCINFO14
-rw-r--r--.gitlab-ci.yml15
-rw-r--r--PKGBUILD25
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a89fba2ee4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-e1071
+ pkgdesc = Functions for latent class analysis, short time Fourier transform, fuzzy clustering, support vector machines, shortest path computation, bagged clustering, naive Bayes classifier, ...
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/e1071
+ arch = x86_64
+ license = GPL
+ depends = r
+ replaces = r-cran-e1071
+ source = https://cran.r-project.org/src/contrib/e1071_1.7-0.tar.gz
+ sha512sums = SKIP
+
+pkgname = r-e1071
+
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..b8b5acf93290
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,15 @@
+image: "imrehg/archlinux-makepkg"
+
+before_script:
+- sudo pacman -Syu --noconfirm
+
+package:
+ script:
+ - makepkg -s --noconfirm
+ artifacts:
+ paths:
+ - pkg/
+ - r-e1071-*.tar.xz
+ expire_in: 2 days
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0dd4567712c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ward Segers <w@rdsegers.be>
+# Contributor: Alex Branham <alex.branham@gmail.com>
+
+_cranver=1.7-0
+pkgname=r-e1071
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc='Functions for latent class analysis, short time Fourier transform, fuzzy clustering, support vector machines, shortest path computation, bagged clustering, naive Bayes classifier, ...'
+arch=('x86_64')
+url='https://cran.r-project.org/web/packages/e1071'
+license=('GPL')
+depends=('r')
+replaces=('r-cran-e1071')
+source=("https://cran.r-project.org/src/contrib/e1071_"$_cranver".tar.gz")
+sha512sums=('SKIP')
+
+build(){
+ R CMD INSTALL e1071_"$_cranver".tar.gz -l "$srcdir"
+}
+
+package() {
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership e1071 "$pkgdir"/usr/lib/R/library
+}
+