summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 08:48:37 +0800
committerSukanka2022-06-06 08:48:37 +0800
commitbd9ff0847beb292df7ac33c4a19e9dba44313dde (patch)
tree2f68d224bed906932fa0a225f2b75ad8df8fe735
downloadaur-bd9ff0847beb292df7ac33c4a19e9dba44313dde.tar.gz
add r-edaseq
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD49
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e189942e438a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = r-edaseq
+ pkgdesc = Exploratory Data Analysis and Normalization for RNA-Seq
+ pkgver = 2.30.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/EDASeq
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationdbi
+ depends = r-aroma.light
+ depends = r-biobase
+ depends = r-biocgenerics
+ depends = r-biocmanager
+ depends = r-biomart
+ depends = r-biostrings
+ depends = r-genomicfeatures
+ depends = r-genomicranges
+ depends = r-iranges
+ depends = r-rsamtools
+ depends = r-shortread
+ optdepends = r-biocstyle
+ optdepends = r-deseq2
+ optdepends = r-edger
+ optdepends = r-kernsmooth
+ optdepends = r-knitr
+ optdepends = r-leebamviews
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ optdepends = r-yeastrnaseq
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/EDASeq_2.30.0.tar.gz
+ sha256sums = 9a1fd96f0c01c0afc524a851d5a955ac0b939a1ad79b08e35155e3dd615dd7e2
+
+pkgname = r-edaseq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27a4b2109dcd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=EDASeq
+_pkgver=2.30.0
+pkgname=r-${_pkgname,,}
+pkgver=2.30.0
+pkgrel=1
+pkgdesc='Exploratory Data Analysis and Normalization for RNA-Seq'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-aroma.light
+ r-biobase
+ r-biocgenerics
+ r-biocmanager
+ r-biomart
+ r-biostrings
+ r-genomicfeatures
+ r-genomicranges
+ r-iranges
+ r-rsamtools
+ r-shortread
+)
+optdepends=(
+ r-biocstyle
+ r-deseq2
+ r-edger
+ r-kernsmooth
+ r-knitr
+ r-leebamviews
+ r-rmarkdown
+ r-testthat
+ r-yeastrnaseq
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('9a1fd96f0c01c0afc524a851d5a955ac0b939a1ad79b08e35155e3dd615dd7e2')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: