summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 08:53:02 +0800
committerSukanka2022-06-06 08:53:02 +0800
commit8a9b62bd92c98e6cba7862b588e4334a26f3f6d4 (patch)
treed35c80d0923acedc88a9c9d8ad9069bbfc4b9803
downloadaur-8a9b62bd92c98e6cba7862b588e4334a26f3f6d4.tar.gz
add r-eir
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff235eee1af7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = r-eir
+ pkgdesc = Accelerated similarity searching of small molecules
+ pkgver = 1.36.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/eiR
+ arch = x86_64
+ license = Artistic2.0
+ depends = r
+ depends = r-biocgenerics
+ depends = r-chemminer
+ depends = r-dbi
+ depends = r-digest
+ depends = r-rcppannoy
+ depends = r-rcurl
+ depends = r-runit
+ depends = r-snow
+ depends = r-snowfall
+ optdepends = r-biocstyle
+ optdepends = r-knitcitations
+ optdepends = r-knitr
+ optdepends = r-knitrbootstrap
+ optdepends = r-rmarkdown
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/eiR_1.36.0.tar.gz
+ sha256sums = 10569b8544b0cfcf456a2086698eb4e9e010bff3a91f2c7618f8a9d91c13db5e
+
+pkgname = r-eir
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40f3fa873a62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=eiR
+_pkgver=1.36.0
+pkgname=r-${_pkgname,,}
+pkgver=1.36.0
+pkgrel=1
+pkgdesc='Accelerated similarity searching of small molecules'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biocgenerics
+ r-chemminer
+ r-dbi
+ r-digest
+ r-rcppannoy
+ r-rcurl
+ r-runit
+ r-snow
+ r-snowfall
+)
+optdepends=(
+ r-biocstyle
+ r-knitcitations
+ r-knitr
+ r-knitrbootstrap
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('10569b8544b0cfcf456a2086698eb4e9e010bff3a91f2c7618f8a9d91c13db5e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: