summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-12-09 12:39:50 +0200
committerPekka Ristola2023-12-09 12:39:50 +0200
commit209bfdb802867a053b0eb620bcf7181c11018111 (patch)
treef49780733751a5543211f63bc6479efcd590409b
downloadaur-209bfdb802867a053b0eb620bcf7181c11018111.tar.gz
Version 1.6.1
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD80
2 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e1f74b3b350
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+pkgbase = r-epimutacions
+ pkgdesc = Robust outlier identification for DNA methylation data
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://bioconductor.org/packages/epimutacions
+ arch = x86_64
+ license = MIT
+ checkdepends = r-testthat
+ depends = r-annotationdbi
+ depends = r-annotationhub
+ depends = r-biocgenerics
+ depends = r-biocparallel
+ depends = r-biomart
+ depends = r-bumphunter
+ depends = r-ensembldb
+ depends = r-epimutacionsdata
+ depends = r-experimenthub
+ depends = r-genomeinfodb
+ depends = r-genomicfeatures
+ depends = r-genomicranges
+ depends = r-ggplot2
+ depends = r-ggrepel
+ depends = r-gridextra
+ depends = r-gviz
+ depends = r-homo.sapiens
+ depends = r-illuminahumanmethylation450kanno.ilmn12.hg19
+ depends = r-illuminahumanmethylation450kmanifest
+ depends = r-illuminahumanmethylationepicanno.ilm10b2.hg19
+ depends = r-illuminahumanmethylationepicmanifest
+ depends = r-iranges
+ depends = r-isotree
+ depends = r-matrixstats
+ depends = r-minfi
+ depends = r-purrr
+ depends = r-reshape2
+ depends = r-robustbase
+ depends = r-rtracklayer
+ depends = r-s4vectors
+ depends = r-summarizedexperiment
+ depends = r-tibble
+ depends = r-txdb.hsapiens.ucsc.hg18.knowngene
+ depends = r-txdb.hsapiens.ucsc.hg19.knowngene
+ depends = r-txdb.hsapiens.ucsc.hg38.knowngene
+ optdepends = r-a4base
+ optdepends = r-biocstyle
+ optdepends = r-kableextra
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/epimutacions_1.6.1.tar.gz
+ md5sums = 73fdaf9db5e5d035601282d6e5d832fd
+ sha256sums = ea5dafb2dd4141bb1ba7ab35a8c2e209932dc47d77afe6eb6ccc0032a12378be
+
+pkgname = r-epimutacions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01fc8d3a654b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=epimutacions
+_pkgver=1.6.1
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Robust outlier identification for DNA methylation data"
+arch=(x86_64)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(MIT)
+depends=(
+ r-annotationdbi
+ r-annotationhub
+ r-biocgenerics
+ r-biocparallel
+ r-biomart
+ r-bumphunter
+ r-ensembldb
+ r-epimutacionsdata
+ r-experimenthub
+ r-genomeinfodb
+ r-genomicfeatures
+ r-genomicranges
+ r-ggplot2
+ r-ggrepel
+ r-gridextra
+ r-gviz
+ r-homo.sapiens
+ r-illuminahumanmethylation450kanno.ilmn12.hg19
+ r-illuminahumanmethylation450kmanifest
+ r-illuminahumanmethylationepicanno.ilm10b2.hg19
+ r-illuminahumanmethylationepicmanifest
+ r-iranges
+ r-isotree
+ r-matrixstats
+ r-minfi
+ r-purrr
+ r-reshape2
+ r-robustbase
+ r-rtracklayer
+ r-s4vectors
+ r-summarizedexperiment
+ r-tibble
+ r-txdb.hsapiens.ucsc.hg18.knowngene
+ r-txdb.hsapiens.ucsc.hg19.knowngene
+ r-txdb.hsapiens.ucsc.hg38.knowngene
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-a4base
+ r-biocstyle
+ r-kableextra
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('73fdaf9db5e5d035601282d6e5d832fd')
+sha256sums=('ea5dafb2dd4141bb1ba7ab35a8c2e209932dc47d77afe6eb6ccc0032a12378be')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}