summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 09:13:01 +0800
committerSukanka2022-06-06 09:13:01 +0800
commit4f4b9a2ce21e18d0f35401578b20766a60ce312b (patch)
tree5f4a5850613141f9f148b2067f29b9387b14e7d1
downloadaur-4f4b9a2ce21e18d0f35401578b20766a60ce312b.tar.gz
add r-erccdashboard
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79775af1d7f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = r-erccdashboard
+ pkgdesc = Assess Differential Gene Expression Experiments with ERCC Controls
+ pkgver = 1.30.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/erccdashboard
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-edger
+ depends = r-ggplot2
+ depends = r-gplots
+ depends = r-gridextra
+ depends = r-gtools
+ depends = r-limma
+ depends = r-locfit
+ depends = r-plyr
+ depends = r-qvalue
+ depends = r-reshape2
+ depends = r-rocr
+ depends = r-scales
+ depends = r-stringr
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/erccdashboard_1.30.0.tar.gz
+ sha256sums = 00c566cd287e273c3d53836fd6f839678c08539722e1ab1798ef27c9c8b8ddda
+
+pkgname = r-erccdashboard
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4c08cf022f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=erccdashboard
+_pkgver=1.30.0
+pkgname=r-${_pkgname,,}
+pkgver=1.30.0
+pkgrel=1
+pkgdesc='Assess Differential Gene Expression Experiments with ERCC Controls'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-edger
+ r-ggplot2
+ r-gplots
+ r-gridextra
+ r-gtools
+ r-limma
+ r-locfit
+ r-plyr
+ r-qvalue
+ r-reshape2
+ r-rocr
+ r-scales
+ r-stringr
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('00c566cd287e273c3d53836fd6f839678c08539722e1ab1798ef27c9c8b8ddda')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: