summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-09-18 18:43:40 +0300
committerPekka Ristola2023-09-18 18:43:40 +0300
commit709c0761a2826ac84b8b11b322c4131c0492bf67 (patch)
treef0595d14f4979856fad9da7ab70c9a5c97628ac8
downloadaur-709c0761a2826ac84b8b11b322c4131c0492bf67.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD69
2 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1a2e1afc606
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = r-estimatr
+ pkgdesc = Fast Estimators for Design-Based Inference
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://cran.r-project.org/package=estimatr
+ arch = x86_64
+ license = MIT
+ checkdepends = r-aer
+ checkdepends = r-car
+ checkdepends = r-clubsandwich
+ checkdepends = r-emmeans
+ checkdepends = r-fabricatr
+ checkdepends = r-margins
+ checkdepends = r-randomizr
+ checkdepends = r-sandwich
+ checkdepends = r-stargazer
+ checkdepends = r-testthat
+ makedepends = r-rcppeigen
+ depends = r-formula
+ depends = r-generics
+ depends = r-rcpp
+ depends = r-rlang
+ optdepends = r-aer
+ optdepends = r-car
+ optdepends = r-clubsandwich
+ optdepends = r-emmeans
+ optdepends = r-estimability
+ optdepends = r-fabricatr
+ optdepends = r-margins
+ optdepends = r-modelsummary
+ optdepends = r-prediction
+ optdepends = r-randomizr
+ optdepends = r-rcppeigen
+ optdepends = r-sandwich
+ optdepends = r-stargazer
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/estimatr_1.0.0.tar.gz
+ md5sums = c8e716d7894d9febfca19b2e8fdfea36
+ sha256sums = a9c8ce7a7f77d4e030052cced599e41376a91de8179e12dd79a5bf4eed91a9df
+
+pkgname = r-estimatr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..526f8806fdb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=estimatr
+_pkgver=1.0.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Fast Estimators for Design-Based Inference"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(MIT)
+depends=(
+ r-formula
+ r-generics
+ r-rcpp
+ r-rlang
+)
+makedepends=(
+ r-rcppeigen
+)
+checkdepends=(
+ r-aer
+ r-car
+ r-clubsandwich
+ r-emmeans
+ r-fabricatr
+ r-margins
+ r-randomizr
+ r-sandwich
+ r-stargazer
+ r-testthat
+)
+optdepends=(
+ r-aer
+ r-car
+ r-clubsandwich
+ r-emmeans
+ r-estimability
+ r-fabricatr
+ r-margins
+ r-modelsummary
+ r-prediction
+ r-randomizr
+ r-rcppeigen
+ r-sandwich
+ r-stargazer
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('c8e716d7894d9febfca19b2e8fdfea36')
+sha256sums=('a9c8ce7a7f77d4e030052cced599e41376a91de8179e12dd79a5bf4eed91a9df')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}