summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 09:18:35 +0800
committerSukanka2022-06-06 09:18:35 +0800
commitc0fe3aaedb38ad608565f0871b4fec0d54cfa62c (patch)
treed699cd9ac03e83f57f13eee21cbd51d4293bce04
downloadaur-c0fe3aaedb38ad608565f0871b4fec0d54cfa62c.tar.gz
add r-evmix
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8a157441881
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-evmix
+ pkgdesc = Extreme Value Mixture Modelling, Threshold Estimation and Boundary Corrected Kernel Density Estimation
+ pkgver = 2.12
+ pkgrel = 3
+ url = https://cran.r-project.org/package=evmix
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-gsl
+ depends = r-sparsem
+ source = https://cran.r-project.org/src/contrib/evmix_2.12.tar.gz
+ sha256sums = 6e47d53463b68ac2782201bcc6240fbc5263b2db1ac0d383062032ab135b2a0b
+
+pkgname = r-evmix
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c85fbd59d53a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=evmix
+_pkgver=2.12
+pkgname=r-${_pkgname,,}
+pkgver=2.12
+pkgrel=3
+pkgdesc='Extreme Value Mixture Modelling, Threshold Estimation and Boundary Corrected Kernel Density Estimation'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-gsl
+ r-sparsem
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('6e47d53463b68ac2782201bcc6240fbc5263b2db1ac0d383062032ab135b2a0b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: