summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 09:23:19 +0800
committerSukanka2022-06-06 09:23:19 +0800
commitdeb6f0fef05edd9af3d9a5b765d84cfd468f0a94 (patch)
tree95c12d22523e5bd68ccd59c4fd1de89cc5ba5726
downloadaur-deb6f0fef05edd9af3d9a5b765d84cfd468f0a94.tar.gz
add r-exploremodelmatrix
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD48
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c11abcb05ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = r-exploremodelmatrix
+ pkgdesc = Graphical Exploration of Design Matrices
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/ExploreModelMatrix
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-cowplot
+ depends = r-dplyr
+ depends = r-dt
+ depends = r-ggplot2
+ depends = r-limma
+ depends = r-magrittr
+ depends = r-rintrojs
+ depends = r-s4vectors
+ depends = r-scales
+ depends = r-shiny
+ depends = r-shinydashboard
+ depends = r-shinyjs
+ depends = r-tibble
+ depends = r-tidyr
+ optdepends = r-biocstyle
+ optdepends = r-htmltools
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/ExploreModelMatrix_1.8.0.tar.gz
+ sha256sums = b59a9b865a9864c63520252b4c9851699facdbf1f4c7e5f4e4e5930fda485594
+
+pkgname = r-exploremodelmatrix
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cef0ba934600
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ExploreModelMatrix
+_pkgver=1.8.0
+pkgname=r-${_pkgname,,}
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='Graphical Exploration of Design Matrices'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-cowplot
+ r-dplyr
+ r-dt
+ r-ggplot2
+ r-limma
+ r-magrittr
+ r-rintrojs
+ r-s4vectors
+ r-scales
+ r-shiny
+ r-shinydashboard
+ r-shinyjs
+ r-tibble
+ r-tidyr
+)
+optdepends=(
+ r-biocstyle
+ r-htmltools
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('b59a9b865a9864c63520252b4c9851699facdbf1f4c7e5f4e4e5930fda485594')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: