summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 16:06:19 -0500
committerAlex Branham2018-05-31 16:06:19 -0500
commitd2fb2400e79bec8ed3cc92fe8006842e257e2d91 (patch)
treee140587e1d6bc6bbe6227afa2106361e385576a8
parent5d48700a7b82c92d0dcef532deac10bda4e61d08 (diff)
downloadaur-d2fb2400e79bec8ed3cc92fe8006842e257e2d91.tar.gz
Upkg 0.999.2 & rename
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 33 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 485fc6e0ba7c..d08224bed465 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
-pkgbase = r-cran-expm
- pkgdesc = Computation of the matrix exponential and related quantities
- pkgver = 0.999_1
+pkgbase = r-expm
+ pkgdesc = Matrix Exponential, Log, etc
+ pkgver = 0.999.2
pkgrel = 1
- url = http://cran.r-project.org/web/packages/expm/index.html
- arch = i686
+ url = https://cran.r-project.org/package=expm
arch = x86_64
- license = GPL3
+ license = GPL
depends = r
- source = http://cran.r-project.org/src/contrib/expm_0.999-1.tar.gz
- md5sums = 071a2899147d12aa29dba9ba4aa901bd
+ optdepends = r-sfsmisc
+ replaces = r-cran-expm
+ source = https://cran.r-project.org/src/contrib/expm_0.999-2.tar.gz
+ md5sums = e05fa3f995754af92bd03227625da984
-pkgname = r-cran-expm
+pkgname = r-expm
diff --git a/PKGBUILD b/PKGBUILD
index 3bb796c9a41d..f7ec9db2746f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,27 @@
-#Maintainer: Orphan
-#generated by: fordprefect <fordprefect@dukun.de>
+# Maintainer: Alex Branham <branham@utexas.edu>
_cranname=expm
-pkgname=r-cran-$_cranname
-_cranver=0.999-1
-pkgver=0.999_1
+_cranver=0.999-2
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-expm
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Computation of the matrix exponential and related quantities"
-url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
-arch=('i686' 'x86_64')
-license=('GPL3')
-depends=('r')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('071a2899147d12aa29dba9ba4aa901bd')
-
+pkgdesc="Matrix Exponential, Log, etc"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL')
+depends=('r' )
+
+optdepends=('r-sfsmisc')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('e05fa3f995754af92bd03227625da984')
+replaces=('r-cran-expm')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
package() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd ${srcdir}
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
}
+