summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 09:24:29 +0800
committerSukanka2022-06-06 09:24:29 +0800
commita2fd3f9262ed4a0ec51cd4abcb1876b121c1b2f8 (patch)
tree180fa8b46be530becc075ea27049b54f018094ec
downloadaur-a2fd3f9262ed4a0ec51cd4abcb1876b121c1b2f8.tar.gz
add r-extradistr
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b3c91aecbfb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = r-extradistr
+ pkgdesc = Additional Univariate and Multivariate Distributions
+ pkgver = 1.9.1
+ pkgrel = 4
+ url = https://cran.r-project.org/package=extraDistr
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-rcpp
+ depends = gcc
+ optdepends = r-actuar
+ optdepends = r-evd
+ optdepends = r-hoa
+ optdepends = r-laplacesdemon
+ optdepends = r-skellam
+ optdepends = r-testthat
+ optdepends = r-triangle
+ optdepends = r-vgam
+ source = https://cran.r-project.org/src/contrib/extraDistr_1.9.1.tar.gz
+ sha256sums = 9990348c4dbc611684fcb58ab8db7e856dfde1c9c86ffb7705f4b3dff6b2d7bf
+
+pkgname = r-extradistr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04bc62bfab51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# system requirements: C++11
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=extraDistr
+_pkgver=1.9.1
+pkgname=r-${_pkgname,,}
+pkgver=1.9.1
+pkgrel=4
+pkgdesc='Additional Univariate and Multivariate Distributions'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-rcpp
+ gcc
+)
+optdepends=(
+ r-actuar
+ r-evd
+ r-hoa
+ r-laplacesdemon
+ r-skellam
+ r-testthat
+ r-triangle
+ r-vgam
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('9990348c4dbc611684fcb58ab8db7e856dfde1c9c86ffb7705f4b3dff6b2d7bf')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: