summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2024-04-12 17:28:41 +0300
committerPekka Ristola2024-04-12 17:28:41 +0300
commitbe40c2718120297ef2918ba71bbeb29b46bba1cc (patch)
tree25cd7748d3e7f9167c0daaba66a59375e589912f
downloadaur-be40c2718120297ef2918ba71bbeb29b46bba1cc.tar.gz
Version 1.6.0
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6aa34f556631
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = r-fastreer
+ pkgdesc = Phylogenetic, Distance and Other Calculations on VCF and Fasta Files
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/fastreeR
+ arch = any
+ license = GPL-3.0-only
+ checkdepends = r-testthat
+ depends = r-ape
+ depends = r-data.table
+ depends = r-dynamictreecut
+ depends = r-r.utils
+ depends = r-rjava
+ depends = r-stringr
+ optdepends = r-biocfilecache
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-memuse
+ optdepends = r-rmarkdown
+ optdepends = r-spelling
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/fastreeR_1.6.0.tar.gz
+ md5sums = e2b7164aeaa305f819536d9b85e4de12
+ b2sums = 773d006ed3f7ead8f6a95c179c28cc776c64a2ce07b7eb1fa8083deac2a480e3c9eb21e4942582b35bb41520401ff8a463ae64fe820aaa9aa680139a80ce27f1
+
+pkgname = r-fastreer
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5873f4d152e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=fastreeR
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Phylogenetic, Distance and Other Calculations on VCF and Fasta Files"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-3.0-only')
+depends=(
+ r-ape
+ r-data.table
+ r-dynamictreecut
+ r-r.utils
+ r-rjava
+ r-stringr
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocfilecache
+ r-biocstyle
+ r-knitr
+ r-memuse
+ r-rmarkdown
+ r-spelling
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('e2b7164aeaa305f819536d9b85e4de12')
+b2sums=('773d006ed3f7ead8f6a95c179c28cc776c64a2ce07b7eb1fa8083deac2a480e3c9eb21e4942582b35bb41520401ff8a463ae64fe820aaa9aa680139a80ce27f1')
+
+build() {
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}