summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 09:40:33 +0800
committerSukanka2022-06-06 09:40:33 +0800
commit5800e6b9e6543372e87321a774e21537fca5def2 (patch)
tree0ccba2a93ad2d2d3c3ebd1caddc4c33b9e52e0d3
downloadaur-5800e6b9e6543372e87321a774e21537fca5def2.tar.gz
add r-fgsea
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD47
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34774bdb3546
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = r-fgsea
+ pkgdesc = Fast Gene Set Enrichment Analysis
+ pkgver = 1.22.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/fgsea
+ arch = x86_64
+ license = MIT
+ depends = r
+ depends = r-bh
+ depends = r-biocparallel
+ depends = r-data.table
+ depends = r-fastmatch
+ depends = r-ggplot2
+ depends = r-gridextra
+ depends = r-rcpp
+ depends = gcc
+ optdepends = r-annotationdbi
+ optdepends = r-geoquery
+ optdepends = r-knitr
+ optdepends = r-limma
+ optdepends = r-org.mm.eg.db
+ optdepends = r-parallel
+ optdepends = r-reactome.db
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/fgsea_1.22.0.tar.gz
+ sha256sums = ef56433dfff96c1ab20737d6af954c1c6f5158fb74654ce875849aa8def3d646
+
+pkgname = r-fgsea
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..740c70302a9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# system requirements: C++11
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=fgsea
+_pkgver=1.22.0
+pkgname=r-${_pkgname,,}
+pkgver=1.22.0
+pkgrel=1
+pkgdesc='Fast Gene Set Enrichment Analysis'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-bh
+ r-biocparallel
+ r-data.table
+ r-fastmatch
+ r-ggplot2
+ r-gridextra
+ r-rcpp
+ gcc
+)
+optdepends=(
+ r-annotationdbi
+ r-geoquery
+ r-knitr
+ r-limma
+ r-org.mm.eg.db
+ r-parallel
+ r-reactome.db
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ef56433dfff96c1ab20737d6af954c1c6f5158fb74654ce875849aa8def3d646')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENCE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: