summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-09-18 16:28:57 +0300
committerPekka Ristola2023-09-18 16:28:57 +0300
commit1ee51915fc20f14c3bff932c7110587f06db97bf (patch)
tree3e4e8c9c85e83b56d85f1dbec5884d512987310c
downloadaur-1ee51915fc20f14c3bff932c7110587f06db97bf.tar.gz
Version 0.11.1
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a7e08bbdd13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = r-fixest
+ pkgdesc = Fast Fixed-Effects Estimations
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://cran.r-project.org/package=fixest
+ arch = x86_64
+ license = GPL3
+ checkdepends = r-data.table
+ depends = r-dreamerr
+ depends = r-numderiv
+ depends = r-rcpp
+ depends = r-sandwich
+ optdepends = r-data.table
+ optdepends = r-ggplot2
+ optdepends = r-knitr
+ optdepends = r-lfe
+ optdepends = r-pander
+ optdepends = r-pdftools
+ optdepends = r-plm
+ optdepends = r-rmarkdown
+ optdepends = r-tinytex
+ source = https://cran.r-project.org/src/contrib/fixest_0.11.1.tar.gz
+ md5sums = bac798f161856e3faab38b599132754c
+ sha256sums = 13fce103daeba66c3960aa6589eb948b9166c467dc91be2ec1bfe953d30fe7e0
+
+pkgname = r-fixest
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a0725906518
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=fixest
+_pkgver=0.11.1
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Fast Fixed-Effects Estimations"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(GPL3)
+depends=(
+ r-dreamerr
+ r-numderiv
+ r-rcpp
+ r-sandwich
+)
+checkdepends=(
+ r-data.table
+)
+optdepends=(
+ r-data.table
+ r-ggplot2
+ r-knitr
+ r-lfe
+ r-pander
+ r-pdftools
+ r-plm
+ r-rmarkdown
+ r-tinytex
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('bac798f161856e3faab38b599132754c')
+sha256sums=('13fce103daeba66c3960aa6589eb948b9166c467dc91be2ec1bfe953d30fe7e0')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" Rscript --vanilla fixest_tests.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}