summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 09:53:32 +0800
committerSukanka2022-06-06 09:53:32 +0800
commit55ef0b183a74eedfd18d9f4cbd1f0fca065ef3c7 (patch)
treebee2965ba2ae079f76225bc0a089ffc1665ba02c
downloadaur-55ef0b183a74eedfd18d9f4cbd1f0fca065ef3c7.tar.gz
add r-flowcut
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0862690a97f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-flowcut
+ pkgdesc = Precise and Accurate Automated Removal of Outlier Events and Flagging of Files Based on Time Versus Fluorescence Analysis
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/flowCut
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-cairo
+ depends = r-e1071
+ depends = r-flowcore
+ depends = r-flowdensity
+ optdepends = r-biocgenerics
+ optdepends = r-knitr
+ optdepends = r-markdown
+ optdepends = r-rmarkdown
+ optdepends = r-runit
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/flowCut_1.6.0.tar.gz
+ sha256sums = 28c55710a56237ac691baef4a6e19e2a83fee24dbb06f2a0bb89c381437f155d
+
+pkgname = r-flowcut
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29ca30ee167b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=flowCut
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='Precise and Accurate Automated Removal of Outlier Events and Flagging of Files Based on Time Versus Fluorescence Analysis'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-cairo
+ r-e1071
+ r-flowcore
+ r-flowdensity
+)
+optdepends=(
+ r-biocgenerics
+ r-knitr
+ r-markdown
+ r-rmarkdown
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('28c55710a56237ac691baef4a6e19e2a83fee24dbb06f2a0bb89c381437f155d')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: