summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-10-20 14:48:47 +0300
committerPekka Ristola2023-10-20 14:48:47 +0300
commit91ff6f659c288a3c466841ffd0ff288cf004e264 (patch)
tree2f49f18c85374e91bbd25c18a09f819c48ed5024
downloadaur-91ff6f659c288a3c466841ffd0ff288cf004e264.tar.gz
Version 3.12.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fd7ed3d83a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-flowworkspacedata
+ pkgdesc = A data package containing two flowJo, one diva xml workspace and the associated fcs files as well as three GatingSets for testing the flowWorkspace, openCyto and CytoML packages.
+ pkgver = 3.12.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/flowWorkspaceData
+ arch = any
+ license = GPL2
+ depends = r
+ source = https://bioconductor.org/packages/release/data/experiment/src/contrib/flowWorkspaceData_3.12.0.tar.gz
+ md5sums = 8d91993dd5a5c5b561a8063ec91046d3
+ sha256sums = 9b23fa66ccbd1385a6b9180f272d61a48ca4dd647b80c5d1ef02ca73e42a9e7c
+
+pkgname = r-flowworkspacedata
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1b5a0a9470c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=flowWorkspaceData
+_pkgver=3.12.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="A data package containing two flowJo, one diva xml workspace and the associated fcs files as well as three GatingSets for testing the flowWorkspace, openCyto and CytoML packages."
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL2)
+depends=(
+ r
+)
+source=("https://bioconductor.org/packages/release/data/experiment/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('8d91993dd5a5c5b561a8063ec91046d3')
+sha256sums=('9b23fa66ccbd1385a6b9180f272d61a48ca4dd647b80c5d1ef02ca73e42a9e7c')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}