summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-09 00:11:40 +0300
committerViktor Drobot2020-03-09 00:11:40 +0300
commitd95eae37d4517e4ec23ae55ff1e5480429e79224 (patch)
treec0f2e588e774073a52ba2c6c6ca0d82e61877b7a
parent5e7485519c5f0df685cfbbd09d1665538a696ac7 (diff)
downloadaur-d95eae37d4517e4ec23ae55ff1e5480429e79224.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
2 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb67d6a96200..ee7f985303c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = r-forcats
- pkgdesc = Tools for working with categorical variables.
+ pkgdesc = Tools for Working with Categorical Variables (Factors)
pkgver = 0.5.0
pkgrel = 1
url = https://cran.r-project.org/package=forcats
- arch = i686
- arch = x86_64
- license = GPL-3
+ arch = any
+ license = GPL3
depends = r>=3.2
depends = r-ellipsis
depends = r-magrittr
@@ -14,10 +13,11 @@ pkgbase = r-forcats
optdepends = r-covr
optdepends = r-ggplot2
optdepends = r-testthat
+ optdepends = r-readr
optdepends = r-knitr
optdepends = r-rmarkdown
optdepends = r-dplyr
- source = http://cran.r-project.org/src/contrib/forcats_0.5.0.tar.gz
+ source = https://cran.r-project.org/src/contrib/forcats_0.5.0.tar.gz
md5sums = efa3b3055e9167fd2a74b4386441eb1c
pkgname = r-forcats
diff --git a/PKGBUILD b/PKGBUILD
index 838037cf9902..fe47332fdffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
-# Maintainer: frichtlm <frichtlm@gmail.com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: frichtlm <frichtlm@gmail.com>
+
_cranname=forcats
_cranver=0.5.0
-pkgname=r-$_cranname
-pkgver=${_cranver}
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Tools for working with categorical variables."
-url="https://cran.r-project.org/package=forcats"
-arch=('i686' 'x86_64')
-license=('GPL-3')
-depends=('r>=3.2' 'r-ellipsis' 'r-magrittr' 'r-rlang' 'r-tibble')
-optdepends=('r-covr' 'r-ggplot2' 'r-testthat' 'r-knitr' 'r-rmarkdown' 'r-dplyr')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('efa3b3055e9167fd2a74b4386441eb1c')
+pkgdesc="Tools for Working with Categorical Variables (Factors)"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL3)
+depends=('r>=3.2' r-ellipsis r-magrittr r-rlang r-tibble)
+optdepends=(r-covr r-ggplot2 r-testthat r-readr r-knitr r-rmarkdown r-dplyr)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('efa3b3055e9167fd2a74b4386441eb1c')
build() {
- cd "${srcdir}"
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l $srcdir
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
package() {
- cd "${srcdir}"
- install -dm0755 "$pkgdir/usr/lib/R/library"
- cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}