summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2022-07-21 22:50:54 +0800
committersukanka2022-07-21 22:50:54 +0800
commit68b1b9c3c645dbeb1f56d3984efadd50e325614c (patch)
treedb26b7bfd23e8fd54c67a99c61887271d83cc150
parentd5df5f2f8424f80c1099c5f6cf5ca6d7b8563098 (diff)
downloadaur-68b1b9c3c645dbeb1f56d3984efadd50e325614c.tar.gz
takeover package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD38
2 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9af22e0d8ffa..f4cffd783260 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = r-formula.tools
pkgdesc = Programmatic Utilities for Manipulating Formulas, Expressions, Calls, Assignments and Other R Objects
pkgver = 1.7.1
- pkgrel = 1
+ pkgrel = 4
url = https://cran.r-project.org/package=formula.tools
arch = any
- license = GPL2
- depends = r>=3.0.0
- depends = r-operator.tools>=1.4.0
+ license = GPL
+ depends = r
+ depends = r-operator.tools
optdepends = r-magrittr
optdepends = r-testthat
source = https://cran.r-project.org/src/contrib/formula.tools_1.7.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 9265be1ca78c..b117265ee539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=formula.tools
-_cranver=1.7.1
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Programmatic Utilities for Manipulating Formulas, Expressions, Calls, Assignments and Other R Objects"
-arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2)
-depends=('r>=3.0.0' 'r-operator.tools>=1.4.0')
-optdepends=(r-magrittr r-testthat)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+_pkgname=formula.tools
+_pkgver=1.7.1
+pkgname=r-${_pkgname,,}
+pkgver=1.7.1
+pkgrel=4
+pkgdesc='Programmatic Utilities for Manipulating Formulas, Expressions, Calls, Assignments and Other R Objects'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-operator.tools
+)
+optdepends=(
+ r-magrittr
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
sha256sums=('4fe0e72d9d96f2398e86cbd8536d0c84de38e5583d4ff7dcd73f415ddd8ca395')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
+# vim:set ts=2 sw=2 et: