summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 10:10:03 +0800
committerSukanka2022-06-06 10:10:03 +0800
commit71139ed0edbd0dc2bef720dbf5e2f31fad143046 (patch)
treed3e53376a2e5ad4b7af7edc77acb13f6516f4b2f
downloadaur-71139ed0edbd0dc2bef720dbf5e2f31fad143046.tar.gz
add r-frma
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..845bf39e7864
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-frma
+ pkgdesc = Frozen RMA and Barcode
+ pkgver = 1.48.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/frma
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-affy
+ depends = r-biobase
+ depends = r-biocgenerics
+ depends = r-dbi
+ depends = r-oligo
+ depends = r-oligoclasses
+ depends = r-preprocesscore
+ optdepends = r-frmaexampledata
+ optdepends = r-hgu133afrmavecs
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/frma_1.48.0.tar.gz
+ sha256sums = dd1b674d55e86e3b3377000587052536845d6d793b7742bb6c1cff3a251918f0
+
+pkgname = r-frma
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3ab8ae6c44c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=frma
+_pkgver=1.48.0
+pkgname=r-${_pkgname,,}
+pkgver=1.48.0
+pkgrel=1
+pkgdesc='Frozen RMA and Barcode'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-affy
+ r-biobase
+ r-biocgenerics
+ r-dbi
+ r-oligo
+ r-oligoclasses
+ r-preprocesscore
+)
+optdepends=(
+ r-frmaexampledata
+ r-hgu133afrmavecs
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('dd1b674d55e86e3b3377000587052536845d6d793b7742bb6c1cff3a251918f0')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: