summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2021-12-05 21:35:01 +0300
committerViktor Drobot2021-12-05 21:35:01 +0300
commitb74a52f40feaf002458299a0b45c4dff982cb791 (patch)
tree116cd949f8a132e79eb08ffa8505bfed03f4f291
parent09f5c516e5e9e92bbb340ffba2fc9e32cc421b81 (diff)
downloadaur-b74a52f40feaf002458299a0b45c4dff982cb791.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7329299ab97c..3b587789f80f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = r-generics
pkgrel = 1
url = https://cran.r-project.org/package=generics
arch = any
- license = GPL2
+ license = MIT
depends = r>=3.2
optdepends = r-covr
optdepends = r-pkgload
diff --git a/PKGBUILD b/PKGBUILD
index cea35447345d..1ed414547fb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,21 +9,18 @@ pkgrel=1
pkgdesc="Common S3 Generics not Provided by Base R Methods Related to Model Fitting"
arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2)
+license=(MIT)
depends=('r>=3.2')
optdepends=(r-covr r-pkgload r-testthat r-tibble r-withr)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
sha256sums=('a2478ebf1a0faa8855a152f4e747ad969a800597434196ed1f71975a9eb11912')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
+
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}