summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 13:57:31 +0000
committerGrey Christoforo2019-02-09 13:57:31 +0000
commit2ab2f4254316ab1c215fa6db07520795d2cfa2c5 (patch)
treed6632ecf0691b8173ae2b6fac5270a61cc5b93c3
downloadaur-2ab2f4254316ab1c215fa6db07520795d2cfa2c5.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90ec8f4a3bd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-genomeinfodbdata
+ pkgdesc = Species and taxonomy ID look up tables used by GenomeInfoDb
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/release/bioc/html/GenomeInfoDbData.html
+ arch = x86_64
+ license = Artistic-2.0
+ depends = r
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/GenomeInfoDbData_1.2.0.tar.gz
+ sha1sums = 9ae8bd8dcad7cb595193f1fa597e22a0ab0ff0a7
+
+pkgname = r-genomeinfodbdata
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c9a9e4d9b8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-genomeinfodbdata
+_bc_name=GenomeInfoDbData
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Species and taxonomy ID look up tables used by GenomeInfoDb"
+url="https://bioconductor.org/packages/release/bioc/html/${_bc_name}.html"
+arch=("x86_64")
+license=('Artistic-2.0')
+depends=('r')
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_bc_name}_${pkgver}.tar.gz")
+sha1sums=('9ae8bd8dcad7cb595193f1fa597e22a0ab0ff0a7')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_bc_name}
+}