summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 14:26:23 +0000
committerGrey Christoforo2019-02-09 14:26:23 +0000
commit339f605096497cc0adb97930171b604122318b9c (patch)
treeb4a6b2625400243f30be478c0c6beaec69080ef1
downloadaur-339f605096497cc0adb97930171b604122318b9c.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52f588ee63c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = r-genomicranges
+ pkgdesc = Representation and manipulation of genomic intervals and variables defined along a genome
+ pkgver = 1.34.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/release/bioc/html/GenomicRanges.html
+ arch = x86_64
+ license = Artistic-2.0
+ depends = r
+ depends = r-biocgenerics
+ depends = r-s4vectors
+ depends = r-iranges
+ depends = r-genomeinfodb
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/GenomicRanges_1.34.0.tar.gz
+ sha1sums = 8c5b4e1bbaa6908145514e3ef2c725789a43395d
+
+pkgname = r-genomicranges
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45b819e67bf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-genomicranges
+_bc_name=GenomicRanges
+pkgver=1.34.0
+pkgrel=1
+pkgdesc="Representation and manipulation of genomic intervals and variables defined along a genome"
+url="https://bioconductor.org/packages/release/bioc/html/${_bc_name}.html"
+arch=("x86_64")
+license=('Artistic-2.0')
+depends=('r' 'r-biocgenerics' 'r-s4vectors' 'r-iranges' 'r-genomeinfodb')
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bc_name}_${pkgver}.tar.gz")
+sha1sums=('8c5b4e1bbaa6908145514e3ef2c725789a43395d')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_bc_name}
+}