summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 10:47:47 +0800
committerSukanka2022-06-06 10:47:47 +0800
commit5649f6642f997c58479adb917f3ef9879e78ae54 (patch)
treeb04fd0b0c78e5930c7a4f721151f70f555aba188
downloadaur-5649f6642f997c58479adb917f3ef9879e78ae54.tar.gz
add r-genomicsupersignature
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD61
2 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5824f46e189
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = r-genomicsupersignature
+ pkgdesc = Interpretation of RNA-seq experiments through robust, efficient comparison to public databases
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/GenomicSuperSignature
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-biobase
+ depends = r-biocfilecache
+ depends = r-complexheatmap
+ depends = r-dplyr
+ depends = r-flextable
+ depends = r-ggplot2
+ depends = r-ggpubr
+ depends = r-plotly
+ depends = r-s4vectors
+ depends = r-summarizedexperiment
+ optdepends = r-bcellviper
+ optdepends = r-biocmanager
+ optdepends = r-biocstyle
+ optdepends = r-circlize
+ optdepends = r-cluster
+ optdepends = r-clusterprofiler
+ optdepends = r-devtools
+ optdepends = r-enrichmentbrowser
+ optdepends = r-forcats
+ optdepends = r-knitr
+ optdepends = r-msigdbr
+ optdepends = r-pkgdown
+ optdepends = r-rcolorbrewer
+ optdepends = r-readr
+ optdepends = r-reshape2
+ optdepends = r-rmarkdown
+ optdepends = r-roxygen2
+ optdepends = r-stats
+ optdepends = r-testthat
+ optdepends = r-tibble
+ optdepends = r-usethis
+ optdepends = r-utils
+ optdepends = r-wordcloud
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/GenomicSuperSignature_1.4.0.tar.gz
+ sha256sums = 7a0e0790de1e64cd08df9f92994ef87f928865810779be895662911de4580e26
+
+pkgname = r-genomicsupersignature
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8a974c95d8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=GenomicSuperSignature
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Interpretation of RNA-seq experiments through robust, efficient comparison to public databases'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biobase
+ r-biocfilecache
+ r-complexheatmap
+ r-dplyr
+ r-flextable
+ r-ggplot2
+ r-ggpubr
+ r-plotly
+ r-s4vectors
+ r-summarizedexperiment
+)
+optdepends=(
+ r-bcellviper
+ r-biocmanager
+ r-biocstyle
+ r-circlize
+ r-cluster
+ r-clusterprofiler
+ r-devtools
+ r-enrichmentbrowser
+ r-forcats
+ r-knitr
+ r-msigdbr
+ r-pkgdown
+ r-rcolorbrewer
+ r-readr
+ r-reshape2
+ r-rmarkdown
+ r-roxygen2
+ r-stats
+ r-testthat
+ r-tibble
+ r-usethis
+ r-utils
+ r-wordcloud
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('7a0e0790de1e64cd08df9f92994ef87f928865810779be895662911de4580e26')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: