summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJooa2018-06-11 08:08:11 +0200
committerJooa2018-06-11 08:08:11 +0200
commitaf5d2a32f177aa38eaea25652a077f09423187f4 (patch)
tree50caee3d501e234535de3273404a3961c13a59b9
downloadaur-af5d2a32f177aa38eaea25652a077f09423187f4.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0c2ec62ccfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-geosphere
+ pkgdesc = Spherical trigonometry for geographic applications.
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://cran.r-project.org/package=geosphere
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = r>=3.0
+ depends = r-sp
+ provides = r-geosphere
+ source = https://cran.r-project.org/src/contrib/geosphere_1.5-7.tar.gz
+ sha256sums = 9d9b555e2d59a5ae174ae654652121f169fbc3e9cf66c2491bfbe0684b6dd8a0
+
+pkgname = r-geosphere
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..756a4459d97e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jooa <aur at (name) dot xyz>
+pkgname=r-geosphere
+pkgver=1.5
+pkgrel=1
+_cranname=geosphere
+_cranrel=7
+_pkgfile=${_cranname}_${pkgver}-${_cranrel}.tar.gz
+pkgdesc="Spherical trigonometry for geographic applications."
+url="https://cran.r-project.org/package=${_cranname}"
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('r>=3.0' 'r-sp')
+provides=('r-geosphere')
+source=(https://cran.r-project.org/src/contrib/${_pkgfile})
+sha256sums=('9d9b555e2d59a5ae174ae654652121f169fbc3e9cf66c2491bfbe0684b6dd8a0')
+
+build() {
+ R CMD INSTALL ${_pkgfile} -l ${srcdir}
+}
+
+package() {
+ install -d ${pkgdir}/usr/lib/R/library
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}