summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 10:53:40 +0800
committerSukanka2022-06-06 10:53:40 +0800
commite0ce457d4abc7d63afe5733e8f53409489c65482 (patch)
treef146a892a9dd1bc91422b3be1b00d42f202be70d
downloadaur-e0ce457d4abc7d63afe5733e8f53409489c65482.tar.gz
add r-geosubmission
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e7c00c258db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-geosubmission
+ pkgdesc = Prepares microarray data for submission to GEO
+ pkgver = 1.48.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/GEOsubmission
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-affy
+ depends = r-biobase
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/GEOsubmission_1.48.0.tar.gz
+ sha256sums = cd1c572963a74c47f816a3a04dcc6298868101c0d896c304de38455a65138756
+
+pkgname = r-geosubmission
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b4afbf56712
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=GEOsubmission
+_pkgver=1.48.0
+pkgname=r-${_pkgname,,}
+pkgver=1.48.0
+pkgrel=1
+pkgdesc='Prepares microarray data for submission to GEO'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-affy
+ r-biobase
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('cd1c572963a74c47f816a3a04dcc6298868101c0d896c304de38455a65138756')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: