summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-23 13:47:52 +0000
committerBioArchLinuxBot2024-02-23 13:47:52 +0000
commit196d3ea3c282adbf2c43e9157f4226f0af864ddb (patch)
treef7e4cbd8b0a12a9b29ebee2c205f59f473d0e3db
parent375e8c335db458dd1076085f60df9a7492fed3f8 (diff)
downloadaur-196d3ea3c282adbf2c43e9157f4226f0af864ddb.tar.gz
[lilac] updated to 3.5.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46a20e8da750..cd6e6097cc87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = r-ggplot2
pkgdesc = Create Elegant Data Visualisations Using the Grammar of Graphics
- pkgver = 3.4.4
+ pkgver = 3.5.0
pkgrel = 1
url = https://cran.r-project.org/package=ggplot2
arch = any
@@ -44,8 +44,8 @@ pkgbase = r-ggplot2
optdepends = r-testthat
optdepends = r-vdiffr
optdepends = r-xml2
- source = https://cran.r-project.org/src/contrib/ggplot2_3.4.4.tar.gz
- md5sums = 13e7ad92c109bb07993373317e428415
- sha256sums = 2d76ec065d3e604d019506f45b3b713ae20f38e47dbebfb5ba1648b47fe63e46
+ source = https://cran.r-project.org/src/contrib/ggplot2_3.5.0.tar.gz
+ md5sums = 81c1b4d3661e2b7d2420f1b01235ed60
+ b2sums = 44e1e46bd3327e953f77431a0a625b06ba7f0ac772f96104935a0978df5115661309e07a12d2439940d8ada429cd06a9d8f5ed6a9119fdd8fd7f83d04d7836de
pkgname = r-ggplot2
diff --git a/PKGBUILD b/PKGBUILD
index ff0ec8aa3e31..ef19a99eace8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@
# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
_pkgname=ggplot2
-_pkgver=3.4.4
+_pkgver=3.5.0
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Create Elegant Data Visualisations Using the Grammar of Graphics"
arch=(any)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(MIT)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('MIT')
depends=(
r-cli
r-glue
@@ -61,12 +61,12 @@ optdepends=(
r-xml2
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('13e7ad92c109bb07993373317e428415')
-sha256sums=('2d76ec065d3e604d019506f45b3b713ae20f38e47dbebfb5ba1648b47fe63e46')
+md5sums=('81c1b4d3661e2b7d2420f1b01235ed60')
+b2sums=('44e1e46bd3327e953f77431a0a625b06ba7f0ac772f96104935a0978df5115661309e07a12d2439940d8ada429cd06a9d8f5ed6a9119fdd8fd7f83d04d7836de')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {