summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Frichtl2018-05-30 20:21:33 -0400
committerMatt Frichtl2018-05-30 20:21:33 -0400
commit31603f09e066c6468f50feb473140696c95e4cfc (patch)
tree5669c6e4f26fa72f1cf0ccddbec183c91b801af4
downloadaur-31603f09e066c6468f50feb473140696c95e4cfc.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD20
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72953b4cd395
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-ggplot2
+ pkgdesc = Create Elegant Data Visualisations Using the Grammar of Graphics
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/ggplot2/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL-2
+ depends = r>=3.1
+ depends = r-digest
+ depends = r-gtable>=0.1.1
+ depends = r-plyr>=1.7.1
+ depends = r-reshape2
+ depends = r-cran-scales>=0.4.1
+ depends = r-tibble
+ depends = r-lazyeval
+ source = http://cran.r-project.org/src/contrib/ggplot2_2.2.1.tar.gz
+ md5sums = 14c5a3507bc123c6e7e9ad3bef7cee5c
+
+pkgname = r-ggplot2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a945e1ad133e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: frichtlm <frichtlm@gmail.com>
+# Contributor: wagnerflo <florian@wagner-flo.net>
+_cranname=ggplot2
+_cranver=2.2.1
+pkgname=r-$_cranname
+pkgver=${_cranver}
+pkgrel=1
+pkgdesc="Create Elegant Data Visualisations Using the Grammar of Graphics"
+url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('i686' 'x86_64')
+license=('GPL-2')
+depends=('r>=3.1' 'r-digest' 'r-gtable>=0.1.1' 'r-plyr>=1.7.1' 'r-reshape2' 'r-cran-scales>=0.4.1' 'r-tibble' 'r-lazyeval')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('14c5a3507bc123c6e7e9ad3bef7cee5c')
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd ${srcdir}
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}