summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Frichtl2020-03-05 18:35:02 -0500
committerMatt Frichtl2020-03-05 18:35:02 -0500
commit86704fd7f829031e182df590d6e0136ed15506ea (patch)
treeb14e33c606693036098afdacac6248692d851a81
parente0e27fb231991575e1c78a7a044de36bae24f885 (diff)
downloadaur-86704fd7f829031e182df590d6e0136ed15506ea.tar.gz
Updated to version 3.3.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86d141af0f9f..e83c49fb64a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = r-ggplot2
pkgdesc = Create Elegant Data Visualisations Using the Grammar of Graphics
- pkgver = 3.2.1
+ pkgver = 3.3.0
pkgrel = 1
url = https://cran.r-project.org/package=ggplot2
arch = i686
@@ -8,13 +8,12 @@ pkgbase = r-ggplot2
license = GPL-2
depends = r>=3.2
depends = r-digest
+ depends = r-glue
depends = r-gtable>=0.1.1
- depends = r-lazyeval
- depends = r-reshape2
+ depends = r-isoband
depends = r-rlang>=0.3.0
depends = r-scales>=0.5.0
depends = r-tibble
- depends = r-viridislite
depends = r-withr>=2.0.0
optdepends = r-covr
optdepends = r-dplyr
@@ -38,8 +37,8 @@ pkgbase = r-ggplot2
optdepends = r-svglite
optdepends = r-testthat
optdepends = r-vdiffr
- source = http://cran.r-project.org/src/contrib/ggplot2_3.2.1.tar.gz
- md5sums = c25ec933439e5219fa3fa925d83868be
+ source = http://cran.r-project.org/src/contrib/ggplot2_3.3.0.tar.gz
+ md5sums = 25941cbd03f34549c60c7e40780bef0
pkgname = r-ggplot2
diff --git a/PKGBUILD b/PKGBUILD
index e207978f2930..d40a378c7167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: frichtlm <frichtlm@gmail.com>
# Contributor: wagnerflo <florian@wagner-flo.net>
_cranname=ggplot2
-_cranver=3.2.1
+_cranver=3.3.0
pkgname=r-$_cranname
pkgver=${_cranver}
pkgrel=1
@@ -9,10 +9,10 @@ pkgdesc="Create Elegant Data Visualisations Using the Grammar of Graphics"
url="https://cran.r-project.org/package=ggplot2"
arch=('i686' 'x86_64')
license=('GPL-2')
-depends=('r>=3.2' 'r-digest' 'r-gtable>=0.1.1' 'r-lazyeval' 'r-reshape2' 'r-rlang>=0.3.0' 'r-scales>=0.5.0' 'r-tibble' 'r-viridislite' 'r-withr>=2.0.0')
+depends=('r>=3.2' 'r-digest' 'r-glue' 'r-gtable>=0.1.1' 'r-isoband' 'r-rlang>=0.3.0' 'r-scales>=0.5.0' 'r-tibble' 'r-withr>=2.0.0')
optdepends=('r-covr' 'r-dplyr' 'r-ggplot2movies' 'r-hexbin' 'r-hmisc' 'r-knitr' 'r-lattice' 'r-mapproj' 'r-maps' 'r-maptools' 'r-multcomp' 'r-munsell' 'r-nlme' 'r-profvis' 'r-quantreg' 'r-rgeos' 'r-rmarkdown' 'r-rpart' 'r-sf' 'r-svglite' 'r-testthat' 'r-vdiffr')
source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('c25ec933439e5219fa3fa925d83868be')
+md5sums=('25941cbd03f34549c60c7e40780bef0')
package() {
mkdir -p ${pkgdir}/usr/lib/R/library