summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-09 01:09:06 +0300
committerViktor Drobot2020-03-09 01:09:06 +0300
commitd760aa4687f3983a9a4b8b43ad67dbe4dc238735 (patch)
treef14f309f3460c64e4e199a4ed59c413beafa6b53
parent8e04b8caeecdca8de2846c32e2476e10f2bfe8c5 (diff)
downloadaur-d760aa4687f3983a9a4b8b43ad67dbe4dc238735.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 26 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c40bac63ed64..0dfb425cea58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,14 +3,14 @@ pkgbase = r-ggplot2
pkgver = 3.3.0
pkgrel = 1
url = https://cran.r-project.org/package=ggplot2
- arch = i686
- arch = x86_64
- license = GPL-2
+ arch = any
+ license = GPL2
depends = r>=3.2
depends = r-digest
depends = r-glue
depends = r-gtable>=0.1.1
depends = r-isoband
+ depends = r-mgcv
depends = r-rlang>=0.3.0
depends = r-scales>=0.5.0
depends = r-tibble
@@ -19,7 +19,7 @@ pkgbase = r-ggplot2
optdepends = r-dplyr
optdepends = r-ggplot2movies
optdepends = r-hexbin
- optdepends = r-hmisc
+ optdepends = r-Hmisc
optdepends = r-knitr
optdepends = r-lattice
optdepends = r-mapproj
@@ -37,7 +37,7 @@ pkgbase = r-ggplot2
optdepends = r-svglite
optdepends = r-testthat
optdepends = r-vdiffr
- source = http://cran.r-project.org/src/contrib/ggplot2_3.3.0.tar.gz
+ source = https://cran.r-project.org/src/contrib/ggplot2_3.3.0.tar.gz
md5sums = a25941cbd03f34549c60c7e40780bef0
pkgname = r-ggplot2
diff --git a/PKGBUILD b/PKGBUILD
index 7924a18efcda..4a20cb791e92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,30 @@
-# Maintainer: frichtlm <frichtlm@gmail.com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: frichtlm <frichtlm@gmail.com>
# Contributor: wagnerflo <florian@wagner-flo.net>
+
_cranname=ggplot2
_cranver=3.3.0
-pkgname=r-$_cranname
-pkgver=${_cranver}
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Create Elegant Data Visualisations Using the Grammar of Graphics"
-url="https://cran.r-project.org/package=ggplot2"
-arch=('i686' 'x86_64')
-license=('GPL-2')
-depends=('r>=3.2' 'r-digest' 'r-glue' 'r-gtable>=0.1.1' 'r-isoband' 'r-rlang>=0.3.0' 'r-scales>=0.5.0' 'r-tibble' 'r-withr>=2.0.0')
-optdepends=('r-covr' 'r-dplyr' 'r-ggplot2movies' 'r-hexbin' 'r-hmisc' 'r-knitr' 'r-lattice' 'r-mapproj' 'r-maps' 'r-maptools' 'r-multcomp' 'r-munsell' 'r-nlme' 'r-profvis' 'r-quantreg' 'r-rgeos' 'r-rmarkdown' 'r-rpart' 'r-sf' 'r-svglite' 'r-testthat' 'r-vdiffr')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL2)
+depends=('r>=3.2' r-digest r-glue 'r-gtable>=0.1.1' r-isoband r-mgcv 'r-rlang>=0.3.0' 'r-scales>=0.5.0' r-tibble 'r-withr>=2.0.0')
+optdepends=(r-covr r-dplyr r-ggplot2movies r-hexbin r-Hmisc r-knitr r-lattice r-mapproj r-maps r-maptools r-multcomp r-munsell r-nlme r-profvis r-quantreg r-rgeos r-rmarkdown r-rpart r-sf r-svglite r-testthat r-vdiffr)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('a25941cbd03f34549c60c7e40780bef0')
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
package() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd ${srcdir}
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}