summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2022-07-21 22:51:24 +0800
committersukanka2022-07-21 22:51:24 +0800
commitf3bf63960022071ca02c7072a93f5f0963712a83 (patch)
treefa455e2774f3f39e7737a04e3e3d154fc9a25537
parent8dcf25a978ce855b8b1337b2a108a972772e6912 (diff)
downloadaur-f3bf63960022071ca02c7072a93f5f0963712a83.tar.gz
takeover package
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD62
2 files changed, 60 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53f3e4295d62..b5bdc20ca0ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,32 @@
pkgbase = r-ggpmisc
- pkgdesc = Provide for uniform handling of R's different time-based data classes by extending zoo, maximizing native format information preservation and allowing for user level customization and extension, while simplifying cross-class interoperability.
+ pkgdesc = Miscellaneous Extensions to 'ggplot2'
pkgver = 0.4.7
pkgrel = 1
url = https://cran.r-project.org/package=ggpmisc
arch = any
license = GPL
- makedepends = r-splus2r
- makedepends = r-lmodel2
- makedepends = r-plyr
- depends = r>=3.6.0
- depends = r-ggpp>=0.4.2
- optdepends = r-knitr
- optdepends = r-rmarkdown
- optdepends = r-ggrepel
+ depends = r
+ depends = r-dplyr
+ depends = r-generics
+ depends = r-ggplot2
+ depends = r-ggpp
+ depends = r-lmodel2
+ depends = r-lubridate
+ depends = r-plyr
+ depends = r-polynom
+ depends = r-quantreg
+ depends = r-rlang
+ depends = r-scales
+ depends = r-splus2r
+ depends = r-tibble
optdepends = r-broom
optdepends = r-broom.mixed
- optdepends = r-nlme
optdepends = r-gginnards
- source = https://cran.microsoft.com/snapshot/2022-06-25/src/contrib/ggpmisc_0.4.7.tar.gz
- sha512sums = 6036065614dd6a443336ebc994e04458df1a56f3761268da369daaa74d508d54a00b3d916aa0fe86e1a9c1aa91c96e4819d340c54ff91d97c76577276b03381b
+ optdepends = r-ggrepel
+ optdepends = r-knitr
+ optdepends = r-nlme
+ optdepends = r-rmarkdown
+ source = https://cran.r-project.org/src/contrib/ggpmisc_0.4.7.tar.gz
+ sha256sums = fd93e10f23c477cc39e3e776b380afeefc31f89283e09605ad6878b8a86536fc
pkgname = r-ggpmisc
diff --git a/PKGBUILD b/PKGBUILD
index f533c0535f47..e58850afce26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,48 @@
-# Maintainer: Robert Greener <me@r0bert.dev>
-# Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=ggpmisc
-_cranver=0.4.7
-_updatedate=2022-06-25
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
+_pkgname=ggpmisc
+_pkgver=0.4.7
+pkgname=r-${_pkgname,,}
+pkgver=0.4.7
pkgrel=1
-pkgdesc="Provide for uniform handling of R's different time-based data classes by extending zoo, maximizing native format information preservation and allowing for user level customization and extension, while simplifying cross-class interoperability."
-arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL)
-depends=('r>=3.6.0' 'r-ggpp>=0.4.2')
-makedepends=(r-splus2r r-lmodel2 r-plyr)
-optdepends=(r-knitr r-rmarkdown r-ggrepel r-broom r-broom.mixed r-nlme r-gginnards)
-source=("https://cran.microsoft.com/snapshot/${_updatedate}/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha512sums=('ebf91f579c54362409253cc18195018077645ea3347202cfc6002a9427911409ab360e07c4ed293a0a6d5cabb43f39fb305547ab5723c82909f3874c2249320b')
+pkgdesc="Miscellaneous Extensions to 'ggplot2'"
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-dplyr
+ r-generics
+ r-ggplot2
+ r-ggpp
+ r-lmodel2
+ r-lubridate
+ r-plyr
+ r-polynom
+ r-quantreg
+ r-rlang
+ r-scales
+ r-splus2r
+ r-tibble
+)
+optdepends=(
+ r-broom
+ r-broom.mixed
+ r-gginnards
+ r-ggrepel
+ r-knitr
+ r-nlme
+ r-rmarkdown
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('fd93e10f23c477cc39e3e776b380afeefc31f89283e09605ad6878b8a86536fc')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
-
+# vim:set ts=2 sw=2 et: