summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-03-01 06:06:32 +0000
committerBioArchLinuxBot2024-03-01 06:06:32 +0000
commitf6595d4ea63c74f6cf0c5f828c8db1aa6b2808b2 (patch)
tree253aeb3d135dc802003b853706164a90be0afbd7
parentb60ff10c36cbe623c2f730d64fedcf6efde2f4c4 (diff)
downloadaur-f6595d4ea63c74f6cf0c5f828c8db1aa6b2808b2.tar.gz
[lilac] updated to 0.1.2-7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de38d38c1f0d..8a0513c3bc97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = r-gitcreds
pkgdesc = Query 'git' Credentials from 'R'
pkgver = 0.1.2
- pkgrel = 5
+ pkgrel = 7
url = https://cran.r-project.org/package=gitcreds
arch = any
license = MIT
- depends = r
depends = git
- optdepends = r-codetools
+ depends = r
optdepends = r-covr
optdepends = r-knitr
optdepends = r-mockery
@@ -16,6 +15,7 @@ pkgbase = r-gitcreds
optdepends = r-testthat
optdepends = r-withr
source = https://cran.r-project.org/src/contrib/gitcreds_0.1.2.tar.gz
- sha256sums = 41c6abcca5635062b123ffb5af2794770eca5ebd97b05c5a64b24fa1c803c75d
+ md5sums = b79f9a70433189507d3eb0bdc07fae6e
+ b2sums = a2ab5d96ef2150b16ee11361675f8d55faddb0eae35a034dd4a7471734818b6f387e342a4923f7ae91466887f648b7b3d965d2dcef9ff5d4ac72412d2dda05bc
pkgname = r-gitcreds
diff --git a/PKGBUILD b/PKGBUILD
index 0db8865d78e9..65022d538736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# system requirements: git
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
_pkgname=gitcreds
_pkgver=0.1.2
pkgname=r-${_pkgname,,}
-pkgver=0.1.2
-pkgrel=5
+pkgver=${_pkgver//-/.}
+pkgrel=7
pkgdesc="Query 'git' Credentials from 'R'"
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
license=('MIT')
depends=(
- r
git
+ r
)
optdepends=(
- r-codetools
r-covr
r-knitr
r-mockery
@@ -26,15 +24,18 @@ optdepends=(
r-withr
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('41c6abcca5635062b123ffb5af2794770eca5ebd97b05c5a64b24fa1c803c75d')
+md5sums=('b79f9a70433189507d3eb0bdc07fae6e')
+b2sums=('a2ab5d96ef2150b16ee11361675f8d55faddb0eae35a034dd4a7471734818b6f387e342a4923f7ae91466887f648b7b3d965d2dcef9ff5d4ac72412d2dda05bc')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: