summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-03-29 12:02:06 +0000
committerBioArchLinuxBot2024-03-29 12:02:06 +0000
commit81a5b81e9fa64504e4a38f22631e762987b7a438 (patch)
treec41082cee33efa30749c6d728ce5a628c9f84373
parent1a754b75f3b42f780b451e7fced43deb6b91e036 (diff)
downloadaur-81a5b81e9fa64504e4a38f22631e762987b7a438.tar.gz
[lilac] updated to 1.74.0-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b254ea03d413..f961ec49847d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = r-gpls
pkgdesc = Classification using generalized partial least squares
pkgver = 1.74.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/gpls
arch = any
- license = Artistic2.0
+ license = Artistic-2.0
depends = r
- optdepends = r-mass
source = https://bioconductor.org/packages/release/bioc/src/contrib/gpls_1.74.0.tar.gz
- sha256sums = 406afeee1ab2ebcc3a5ec952acf0143e558d130668a48e36147e612e196ed5fc
+ md5sums = db6bc720156a5f7571a34e64b1189d3b
+ b2sums = f647d89a455f050a3189a23cca82b14697f1ea5aebd6851900353cee91747f52f66f4d97550fa0d8c14a57fd97993ed8fadd11110aaf108cfd91e8d7a2ba61ca
pkgname = r-gpls
diff --git a/PKGBUILD b/PKGBUILD
index 54c23fe6cb68..fcb2e81dcb8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,25 @@
_pkgname=gpls
_pkgver=1.74.0
pkgname=r-${_pkgname,,}
-pkgver=1.74.0
-pkgrel=1
-pkgdesc='Classification using generalized partial least squares'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Classification using generalized partial least squares"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('Artistic-2.0')
depends=(
r
)
-optdepends=(
- r-mass
-)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('406afeee1ab2ebcc3a5ec952acf0143e558d130668a48e36147e612e196ed5fc')
+md5sums=('db6bc720156a5f7571a34e64b1189d3b')
+b2sums=('f647d89a455f050a3189a23cca82b14697f1ea5aebd6851900353cee91747f52f66f4d97550fa0d8c14a57fd97993ed8fadd11110aaf108cfd91e8d7a2ba61ca')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: