summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:36:57 +0800
committerSukanka2022-06-06 11:36:57 +0800
commitd5b6c622802a5b5c7ceaab31d13ac19909051fcd (patch)
tree083540f3ea2d530103d03beb3e7d99a146929218
downloadaur-d5b6c622802a5b5c7ceaab31d13ac19909051fcd.tar.gz
add r-gpls
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c56a62cc0e99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-gpls
+ pkgdesc = Classification using generalized partial least squares
+ pkgver = 1.68.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/gpls
+ arch = any
+ license = Artistic2.0
+ depends = r
+ optdepends = r-mass
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/gpls_1.68.0.tar.gz
+ sha256sums = 2b7adc5db3555ade6efbd8bd2cd69cfb1172ae3e66f174059947ad7b264d242a
+
+pkgname = r-gpls
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ded17b7abc12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=gpls
+_pkgver=1.68.0
+pkgname=r-${_pkgname,,}
+pkgver=1.68.0
+pkgrel=1
+pkgdesc='Classification using generalized partial least squares'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+)
+optdepends=(
+ r-mass
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2b7adc5db3555ade6efbd8bd2cd69cfb1172ae3e66f174059947ad7b264d242a')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: