summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:38:09 +0800
committerSukanka2022-06-06 11:38:09 +0800
commit38358a3595ebc79f041aa6c2ffd84391c12a5135 (patch)
treefd0bc196e586ff027490c32d69584f09d5874f1a
downloadaur-38358a3595ebc79f041aa6c2ffd84391c12a5135.tar.gz
add r-gprofiler2
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00430c6310b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = r-gprofiler2
+ pkgdesc = Interface to the 'g:Profiler' Toolset
+ pkgver = 0.2.1
+ pkgrel = 4
+ url = https://cran.r-project.org/package=gprofiler2
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-crosstalk
+ depends = r-dplyr
+ depends = r-ggplot2
+ depends = r-gridextra
+ depends = r-jsonlite
+ depends = r-plotly
+ depends = r-rcurl
+ depends = r-tidyr
+ depends = r-viridislite
+ optdepends = r-knitr
+ optdepends = r-prettydoc
+ optdepends = r-rmarkdown
+ source = https://cran.r-project.org/src/contrib/gprofiler2_0.2.1.tar.gz
+ sha256sums = 2fac15b65921d95b1d360ad3f60bf9c077ab806dd69702736aeff73216191064
+
+pkgname = r-gprofiler2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e5aa66094f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=gprofiler2
+_pkgver=0.2.1
+pkgname=r-${_pkgname,,}
+pkgver=0.2.1
+pkgrel=4
+pkgdesc="Interface to the 'g:Profiler' Toolset"
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-crosstalk
+ r-dplyr
+ r-ggplot2
+ r-gridextra
+ r-jsonlite
+ r-plotly
+ r-rcurl
+ r-tidyr
+ r-viridislite
+)
+optdepends=(
+ r-knitr
+ r-prettydoc
+ r-rmarkdown
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2fac15b65921d95b1d360ad3f60bf9c077ab806dd69702736aeff73216191064')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: