summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:39:04 +0800
committerSukanka2022-06-06 11:39:04 +0800
commit52c9830616b5e211e7e6fcb76c031674c24f3220 (patch)
tree63635c96db2cb2a83c09173ee4c676f7aa06bb76
downloadaur-52c9830616b5e211e7e6fcb76c031674c24f3220.tar.gz
add r-gpumagic
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8565fc6608e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = r-gpumagic
+ pkgdesc = An openCL compiler with the capacity to compile R functions and run the code on GPU
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/gpuMagic
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-biocgenerics
+ depends = r-deriv
+ depends = r-desctools
+ depends = r-digest
+ depends = r-pryr
+ depends = r-rcpp
+ depends = r-stringr
+ depends = ocl-icd
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/gpuMagic_1.12.0.tar.gz
+ sha256sums = f423dae0cfeb14ec90f361cb3565fb3653c4fc53b1981d8780ce48c981eedfbc
+
+pkgname = r-gpumagic
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6e6ccbd3aa9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# system requirements: 1. C++11, 2. a graphic driver or a CPU SDK. 3. ICDloader For Windows user, an ICD loader is required atC:/windows/system32/OpenCL.dll (Usually it is installed by thegraphic driver). For Linux user (Except mac):ocl-icd-opencl-dev package is required. For Mac user, no actionis needed for the system has installed the dependency. 4. GNUmake
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=gpuMagic
+_pkgver=1.12.0
+pkgname=r-${_pkgname,,}
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='An openCL compiler with the capacity to compile R functions and run the code on GPU'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-deriv
+ r-desctools
+ r-digest
+ r-pryr
+ r-rcpp
+ r-stringr
+ ocl-icd
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+makdepends=(
+ make
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f423dae0cfeb14ec90f361cb3565fb3653c4fc53b1981d8780ce48c981eedfbc')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: