summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:41:02 +0800
committerSukanka2022-06-06 11:41:02 +0800
commit36541fa05353a23d631e9aab3cd513b8397c5027 (patch)
tree2d1be7e33217c3e2f82459a4621f74d19793bff9
downloadaur-36541fa05353a23d631e9aab3cd513b8397c5027.tar.gz
add r-graper
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc00564545c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = r-graper
+ pkgdesc = Adaptive penalization in high-dimensional regression and classification with external covariates using variational Bayes
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/graper
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-bh
+ depends = r-cowplot
+ depends = r-ggplot2
+ depends = r-matrixstats
+ depends = r-rcpp
+ depends = r-rcpparmadillo
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/graper_1.12.0.tar.gz
+ sha256sums = 67918e9e349458e3e2b7e6b76f8d7efcd24d71684f2d8ed6abff75961a99aea1
+
+pkgname = r-graper
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..723656b29c71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=graper
+_pkgver=1.12.0
+pkgname=r-${_pkgname,,}
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='Adaptive penalization in high-dimensional regression and classification with external covariates using variational Bayes'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-bh
+ r-cowplot
+ r-ggplot2
+ r-matrixstats
+ r-rcpp
+ r-rcpparmadillo
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('67918e9e349458e3e2b7e6b76f8d7efcd24d71684f2d8ed6abff75961a99aea1')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: